GPIO on FXT0009

hi everyone!

I´m having some troubles using GPIO on Fastrack Xtend (FXT0009), and the real trouble is that I don´t have an idea how it works!!!

Reading some documentation I found that I have to connect the Vref line to 13V , and GPIO lines to ground (Im using 10k pull down buttons between GPIO and ground).

Im reading de signals with the following AT commands:
AT+WIOM=1,”GPIO21”,0  this command activates GPIO21 as an input.
AT+WIOR=”GPIO21”  this command reads the GPIO21 level and
returns the value “1” which represents a HIGH level.

But when I press (and hold) the button i can´t get a change of the signal.

Is my form of wiring the trouble ?
Can anyone post a circuit that can be useful for this case? , at commands or some else that can help me.

Thanks and best regards.


(sorry my english, Im from México).


Can you please look into Product and Technical Specification guide for FXT009 in order to get some guideline.


hi, i also just received my FXT009 and i need to read digital input signals (to be more specific i need to decect if the two output pins of a relais are connected or not). after reading the “AirLink FXT Series User Guide” i’m not sure if i have to use resistors in the wiring. for a quick test, can i just use the shipped 6-wire cable and connect Vref to DC IN (12V) and then connect one of the GPIO pins with either Vref or GND? i don’t want to damage the FXT009 by doing something wrong. is there some wiring guide? or can you provide a link to the “Product and Technical Specification guide for FXT009” that you mentioned? i didn’t find a document with that name so far.

thanks for your help!

ok, i found this article which nicely explains pull-up and pull-down resistors:
after reading this it seemed safe to connect a GPIO pin to ground and i tried it and it worked fine. i didn’t connect Vref to DC IN btw. i’m still not sure about this part but it seems it’s not neccessary for my project.