Gmm-g3 gsv update stop and lost all satellites


#1

I’m use gmm-g3 modules.
gmm-g3 power on -> gets 16 satelite.
But about 3-4 hours later, lost all satellites.
10-30minutes later gets 15 satelite.
But about 3-4 hours later, lost all satellites.
(Repeat this cycle)

Sometimes this phenomenon does not appear.
if appear this cycle, NMEA’s GSV position is not update. (but S/N is update).
and Satellite Number is not update.

1cycle after(lost all satellites), Satellite Number is update.

Am I misconfiguring somewhere?

[add12/2]
I check Gmm-g3 EV-Board (firmware ver5.11).
power on -> 30minute after gsv is updated.
send “hot start” command -> gsv is not updated.
My board has EDLC -> hot start or warm start.
Gmm-g3 and XM series are same firmware.
If you have XM board , please check.

[add 12/3]
Gms-g9 v3.1 OK
Gmm-g3 v3.2 OK
(AXN3.20_8030_3333_96.1151100.1.bin)
Gmm-g3 v3.8 NG
(AXN3.8_8340_3333_96.1151101.1.bin)
Gmm-g3 v3.8 OK
(AXN3.8_8397_3333_96.1151100.1.bin)
Gmm-g3 v5.11 NG
(AXN5.1.1_8524_3333_1152.1151100.1.bin)
Is this firmware bug?


#2

I upload 2 png file.
2018/12/01 13:17 and 2018/12/01 14:17.
Please look GSV datas!.
You can see the same data other than s/n ratio.
I test firmware ver 3.8 and ver 5.1.1, both cause this trouble.


#3


#4

@atec,

It could be a bug but unlikely given it is not generically seen as this would become apparent quite quickly. Please make sure you use 5.1.1 firmware. What settings have you applied to the unit beyond the normal defaults i.e. set the unit to use a specific constellation, periodic mode, etc?

Regards

Matt


#5

I set WGS and GPS/GLONASS and output sentences at my board.
GPS is normal mode(alway working).

If you have gmm-g3 EV-Board, Send to gmm-g3 "$PMTK10132" power on after 30minute. GGSV data is not updated and lost satellites.

There are times to repeat and not repeat.

under png picture is not repeat version .


#6

@atec,

So just to be clear.

  • Run 5.1.1 firmware
  • Set the unit to output all NMEA sentences?
  • Perform a hot restart every 30 minutes?

When you perform the hot restart the unit may or may not re acquire the SV’s?

Regards

Matt


#7

I use ver5.11 firmware.

Set the unit to output all NMEA sentences?
$PMTK314,0,1,1,1,1,0,0,0,0,0,0,0,0,0,0,0,0,1,0
or
$PMTK314,1,1,1,1,1,1,0,0,0,0,0,0,0,0,0,0,0,1,0
@ My Board

Gmm-g3 EV Board is not set sentences(default used).

Perform a hot restart every 30 minutes?
No, once only at Gmm-g3 EV Board.

My board has EDLC backup, so My board start “HOT or Warm” mode.
(It occurs without “HOT START” command at my board.)


#8

@atec,

I just ran a test where I got the unit to do a hot restart every 60 seconds meaning the first acq was effectively a cold start which is still managed to do within the 60 second window, all of the other ‘hot’ starts re-acquired the SV’s immediately.

I have attached the log file and terterm script I used to perform the test.

Regards

Matt


#9

and here’s the attachment…

XM110 hotstart.zip (45.6 KB)


#10

Dear mlw

this is log file.

http://4river.a.la9.jp/gps/index.htm
NMEA monitor can play this file.

gmm_g3_ref_v511 (2).7z (1.26 MB)


#11

[Gmm-g3 EV-Board]
Why exec “HOT START” command every 60second?
When gps received command, gps renew gsv datas, but gps must update gsv datas always.
send “HOT START” 30minute after of power-on only once.


#12

I want to confirm this motion the behavior is correct.
this motion = When gps receive “HOT Start” command, gps stops renew gsv datas.

If so, what is the difference between when the update stops and when it does not stop?

[add]
I try AXN5.1.1_8525_3333_1152.1151100.1.bin.
What change? Where release report?


#13

Release notes for 5.1.1 are at the below link.

https://source.sierrawireless.com/resources/airprime/software/release_notes/airprime_gmm_g3_xa_and_xm_series_firmware_5_1_1_customer_release_note/

Regards

Matt


#14

Thank you.

But the release_note is for AXN5.1.1_8522_3333_1152.1151100.1.
I want to release_note for AXN5.1.1_8525_3333_1152.1151100.1.bin.


#15

@atec,

The 8522 and 8525 are minor configuration differences (which interfaces are enabled at factory production time) , the basic firmware and the changes supplied are the same.

Regards

Matt


#16

I learned that there was a bug in mtk3333.
“QZSS Unit 1” only firmware -> repeat “motion of update stops”.
“QZSS Unit 1,2 and 4” firmware -> repeat “motion of update stops” is fixed.

png picture is not repeat version(“QZSS Unit 1,2 and 4” firmware), Repeat behavior has been fixed, but lose sight of the satellite.
And mediatek may not even know this.


#17

@atec,

There was an issue in the MTK stack, yes, but this was resolved in our firmware 5.1.1 so you need to be a little more specific over the issue and what you are seeing.

Regards

Matt


#18

I do not think that all the problems were solved.
Operation that the position update of the satellite is not performed remains.

I want to check if “firmware ver5.11 8525” is the latest firmware of mediatek.

$PMTK705,AXN_5.1.1_3333_17081700,8525,Gmm-g3,1.0*1E
This show 2017-08 release?
Is there really no new release?


#19

@atec,

Not sure about the dates it was built, etc but it was only released March/April 18, re the actual question, no there have not been any additional releases.

https://source.sierrawireless.com/resources/airprime/software/firmware-xa1110-dev-kit/

https://source.sierrawireless.com/resources/airprime/software/release_notes/airprime_gmm_g3_xa_and_xm_series_firmware_5_1_1_customer_release_note/

Regards

Matt


#20

The important thing about this problem is MediaTek’s firmware release date.
I think that It was not Sierra that solved the QZSS problem, it was MediaTek.
Is Sierra’s firmware really based on the latest release of MediaTek’s firmware?
Such a problem may occur if it is not based on the latest firmware.