Getting GPS Coordinates using NMEA


I am trying to get GPS coordinates using NMEA but failing to do so.

  1. My /etc/legato/usbmode file contains “nmea”

  2. i’ve tried

echo "\$GPS_START" > /dev/nmea
  1. then
cat /dev/nmea

gives the following o/p

$GPVTG,,T,,M,,N,,K,N*2C $GPGSA,A,1,,,,,,,,,,,,,,,*1E $GPGGA,,,,,,0,,,,,,,,*66 $PQXFI,,,,,,,,,,*56 $GPRMC,,V,,,,,,,,,,N*53

I was supposed to get a more detailed “$GPRMC” right ??

Am i missing something ?
Please guide.


Only when you have a valid GPS fix :exclamation:

The ‘V’ in the RMC sentence indicates that you do not have a valid GPS fix.

Thanx a lot…that solved the problem :slight_smile:

Hi, is GPS supported on WP85 board ? Coz I was facing issues while trying to run it on WP85…


The mangoh board GPS does not currently work out of the box with an active GPS antenna. The problem is that the existing HW release does not supply a bias voltage to the antenna

Two options to work around this

  1. Use a passive gps antenna -in practice a standard GSM / 3G stub antenna will work
  2. Add a bias voltage to the GPS feed (be careful you could damage your hardware if you are not familiar with doing this)