FX30s cp causes "I/O Error, both of real entry and whiteout found"

Hi, this is related to a post in the legato forum [Legato Forum Topic LInk](https://forum.legato.io/t/help-startlegato-sh-dissappeards-from-etc-init-d/5926/11), but I am wondering if this is related the HW (or rather flash write cycle limit) on the FX30, which you might know more about.

But basically I have a script that on start up replace the startlegato.sh (not a good design which I will improve… but I have many modems in the field with this set up).

In certain circumstances the modem could reboot every 5mins… cause many writes to /etc/init.d

I get the following error message when trying to copy the file in using cp

input/output error linux

And then with dsmeg I see the following error in towards the end of the log

aufs au_lkup_dentry:223:chmod[844]: I/O Error, both of real entry and whiteout found, startlegato.sh, err -5
I am not linux expect, so need to assisstance… Please :slight_smile:

a) Any ideas what can cause this (considering my setup)
b) how to prevent it
c) how to recover from it.


Hi karlkuhn,

Can you try with file permissions?
chmod 777 Startlegato.sh

Hi Donald, thank you for your reply. I will give that a go when next I set up a session (probably Thursday/Friday).

What are you guessing is the problem? A file in a strange state?

Hi karlkuhn,

It can be the mode of a file. Permission to read/write the file.

Hi Donald, I got the same error when trying to chmod as suggested.

I think something is a corruption on the file system or flash? I tried a factory reset to see if I could recover this part of the file system… but that did not work… so I tried reflashing the mcu*.cwe and my legato.cwe which also did not recover that part of the system.

Each time the startlegato.sh file is not there… but I can’t cp a new one in either.

Is there a way for me to have the whole filesystem effectively reformatted and restored to the factory default?

The factory reset did not replace those files in /etc/init.d nor remove any file from my home directory…


Reading more into this… It seems to be a problem with the state of the “whiteout” files in relations to the aufs filesystem which is a “union” style filesystem… but I do not know enough about this to work out how to resolve it… i.e. it seems to have become out of synch (as hinted by the above error message)

Anyone at Sierra Wireless understand this better. That might be able to help me resolve this?


I’ve managed to resolve the problem. It was a “corruption” of the filesystem that was stopping me getting the system to run normally again… I’ve detailed the solution in the related post in forum.legato.io