[Fx30] GPIO3 on the IoT expansion connector is not stable during power-up


#1

Hello,

Using the expansion connector I see that the GPIO3 (GPIO13 on Linux) goes to low level during about 10 sec after the power up of the Fx30. Then we have a pulse of the n_RESET line and its value moves to high level.
All other expansion connector GPIO (1, 2 and 4) stay always on the high level.

I observed this behaviour on several Fx30 and Fx30s.

Because I’m working on a system which cannot tolerate transient state during the Fx30 power-up. I’m planning to use GPIO1 and 2 only, setting the ACTIVE level of my system to the low level of the GPIO. This way, my system will be in INACTIVE state during the Fx30 power-up… and as long as my control software is not started.

Can-I assume that this low level state during power-up only affects GPIO3, so by working with GPIO1 and 2 I will not have the problem?

Thanks, Christian.


#2

Hi Christian,
I wouldn’t expect any of the IOT expansion connector GPIO to have a pulse as they are all GPIO routed directly from the WP module.

Perhaps you could try:
AT+WIOCFG=13,4
then reboot your system and see if the pulse is still there.

BR,
Chris


#3

Hello Chris,

Here is the GPIO configuration before the WIOCFG command:

root@Fx30-DrBox:~# modem /dev/ttyAT 230400 AT+WIOCFG?

    +WIOCFG: 2,16,0,0,1,0,0
    +WIOCFG: 6,16,0,0,1,0,0
    +WIOCFG: 7,16,0,0,1,0,0
    +WIOCFG: 8,16,0,0,1,0,0
    +WIOCFG: 13,16,0,0,1,0,0
    +WIOCFG: 21,16,0,0,1,0,0
    +WIOCFG: 22,16,0,0,1,0,0
    +WIOCFG: 23,16,0,0,1,0,0
    +WIOCFG: 24,16,0,0,1,0,0
    +WIOCFG: 25,16,0,0,1,0,0
    +WIOCFG: 28,16,0,0,1,0,0
    +WIOCFG: 29,16,0,0,1,0,0
    +WIOCFG: 30,16,0,0,1,0,0
    +WIOCFG: 31,16,0,0,1,0,0
    +WIOCFG: 32,16,0,0,1,0,0
    +WIOCFG: 33,16,0,0,1,0,0
    +WIOCFG: 34,0,0,0,1,0,0
    +WIOCFG: 35,0,0,0,1,0,0
    +WIOCFG: 36,0,0,0,1,0,0
    +WIOCFG: 37,0,0,0,1,0,0
    +WIOCFG: 42,16,0,0,1,0,0

    OK

After changing the GPIO13 from “Embedded host” (16) to “General IO” (4), and power cycle, the result is still the same.
I have tried playing with the direction, the state, the pull of the GPIO trying the various options of the AT command, but the power-up sequence is always the same: a low level on GPIO13 during some seconds at the Fx30 power up.

Regards, Christian.


#4

Hi Christian,
I’ve consulted internally and there should be no reason why GPIO13 is different from the other IOT GPIO.

Could you please clarify, when you are taking these measurements, is your IOT card inserted? If it is, do the GPIOs respond in the same way without it?

BR,
Chris


#5

Hello Chris,

To see what is going on the IoT gpios, I am using a breakout board allowing me to extract the IoT gpios signals out of the Fx30. I then connect those GPIOs to LEDs after going through a buffer/driver circuit (SN74LS06). The IoT IO3 is clearly low during some seconds after the power-up till the moment the n_reset kicks in, then all IOs goes high (or high impedance).

Regards, Christian.


#6

Hi Christian,
Would it be possible to verify if the same behaviour is on the mangOH board directly out of the WP module, before any buffering?
BR,
Chris


#7

Hello Chris,

Sorry it is not possible for me as I do not have the mangOH board.

Best Regards, Christian.