Freezing of tasks aborted on wp7608 of mangOh_red


#1

Hi All,

After powering on the magOH red with wp7608. In the linux console i get the following error and from then the console is unresponsive

root@swi-mdm9x28:/# [ 59.977961] Freezing of tasks aborted after 0.006 seconds

I had updated the software to latest release 9 . Below is the software version. But still the problem exists

root@swi-mdm9x28:~# cm info
Device: WP7608
IMEI: 352913090102771
IMEISV: 4
FSN: XG814285080710
Firmware Version: SWI9X07Y_02.16.02.00 000000 jenkins 2018/[ 28.304945] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x0c1300c8 OPER:0x00000090
04/19 19:59:02
Bootloader Version: SWI9X07Y_02.16.02.00 000000 jenkins 2018/04/19 19:59:02
MCU Version: 002.009
PRI Part Number (PN): 9907762
PRI Revision: 001.002
Carrier PRI Name: GENERIC
Carrier PRI Revision: 002.032_000
SKU: 1103788
Last Reset Cause: Power Down
Resets Count: Expected: 105 Unexpected: 15

Some one faced this problem ?

Thanks,
Siva


#2

Looks like normal behavior to enter sleep mode.

Please try below and see does behavior change:

  1. connect USB cable to PC (driver must be ready)
  2. create wake lock (before it sleep), i.e.

echo test > /sys/power/wake_lock)

  1. enable DevMode

For more info:
https://docs.legato.io/latest/conceptsPwrMgmt.html
https://docs.legato.io/latest/basicTargetDevMode.html

Thx


#3

Hi ,

I would like to disable this feature of entering into sleep mode by default without running this "echo test "command.
Is there any quick way to achieve this functionality to disable by default

Thanks,
Siva


#4

Hi Siva,

In case you don’t like to send the command, you may consider:

  1. install devMode app
    https://docs.legato.io/latest/basicTargetDevMode.html

  2. remove autosleep from init

    mv /etc/init.d/enable_autosleep.sh ~

Hope it helps.


#5

No this didn’t work. I have moved the autosleep script to the home folder. But still the console gets frozen with the below prints. Any Idea how to disable this ?

[ 23.778806] mdm9607-asoc-snd soc:sound-wm8944: ASoC: Failed to add route SPKOUTP -> direct -> Lineout_1 amp
[ 23.810538] mdm9607-asoc-snd soc:sound-wm8944: ASoC: no source widget found for SPKOUTN
[ 23.817543] mdm9607-asoc-snd soc:sound-wm8944: ASoC: Failed to add route SPKOUTN -> direct -> Lineout_3 amp
[ 23.842831] mdm9607-asoc-snd soc:sound-wm8944: ASoC: no source widget found for Mic Bias
[ 23.854349] mdm9607-asoc-snd soc:sound-wm8944: ASoC: Failed to add route Mic Bias -> direct -> IN1
[ 23.867264] mdm9607-asoc-snd soc:sound-wm8944: ASoC: no source widget found for Headset Mic
[ 23.882216] mdm9607-asoc-snd soc:sound-wm8944: ASoC: Failed to add route Headset Mic -> direct -> Mic Bias
[ 23.899245] mdm9607-asoc-snd soc:sound-wm8944: ASoC: no source widget found for MCLK
[ 23.913204] mdm9607-asoc-snd soc:sound-wm8944: ASoC: Failed to add route MCLK -> direct -> Mic Bias
[ 60.931450] Freezing of tasks aborted after 0.007 seconds
[ 61.011385] Freezing of tasks aborted after 0.007 seconds
[ 61.162126] PM: Some devices failed to suspend, or early wake event detected
[ 61.517105] Freezing of tasks aborted after 0.007 seconds
[ 61.616862] PM: Some devices failed to suspend, or early wake event detected
[ 62.166781] Freezing of tasks aborted after 0.007 seconds


#6

After move, have you reboot the board?

Can you check the return of below?

ls /etc/init.d/enable_autosleep.sh -l
cat /sys/power/autosleep

Thx


#7

Yes the board is rebooted
ls /etc/init.d/en* -l --> no such file or directory
root@swi-mdm9x28:~# cat /sys/power/autosleep
mem


#8

Thanks Siva.

/sys/power/autosleep return “mem” means it will auto sleep.

Sorry that I don’t have WP7608 so cannot check further.
What if try move back enable_autosleep.sh file to /etc/init.d/ but modify it to set “off” instead of “mem”?