Fedora MC7700 QMI Driver Errors

Hello There!

I’ve recently purchased an MC7700 IoT Module and I’m trying to make it work on a Windows 10/Fedora 36(KDE Plasma) dual booted laptop.

It runs fine on Windows but I can’t seem to get it set up on Fedora.
I’ve followed the build instruction in the readme but hit a roadblock.

When I run this command " sudo dkms build --verbose -m SierraLinuxQMIdrivers -
v S2.42N2.64"

I get a

(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.19.8-200.fc36.x86_64 (x86_64)
Consult /var/lib/dkms/SierraLinuxQMIdrivers/S2.42N2.64/build/make.log for more information.

Here is the make.log :

DKMS make.log for SierraLinuxQMIdrivers-S2.42N2.64 for kernel 5.19.8-200.fc36.x86_64 (x86_64)
Fri Sep 16 12:10:06 PM CEST 2022
make: Entering directory ‘/var/lib/dkms/SierraLinuxQMIdrivers/S2.42N2.64/build/GobiSerial’
rm -rf *.o ~ core .depend ..cmd *.ko .mod.c .tmp_versions Module. modules.order .cache.mk .o.ur-safe
make -C /lib/modules/5.19.8-200.fc36.x86_64/build M=/var/lib/dkms/SierraLinuxQMIdrivers/S2.42N2.64/build/GobiSerial modules
make[1]: Entering directory ‘/usr/src/kernels/5.19.8-200.fc36.x86_64’
CC [M] /var/lib/dkms/SierraLinuxQMIdrivers/S2.42N2.64/build/GobiSerial/GobiSerial.o
/var/lib/dkms/SierraLinuxQMIdrivers/S2.42N2.64/build/GobiSerial/GobiSerial.c:242:2: warning: #warning “Assuming disc_mutex is locked external to the module” [-Wcpp]
242 | #warning “Assuming disc_mutex is locked external to the module”
| ^~~~~~~
/var/lib/dkms/SierraLinuxQMIdrivers/S2.42N2.64/build/GobiSerial/GobiSerial.c:773:27: error: initialization of ‘void (
)(struct usb_serial_port )’ from incompatible pointer type ‘int ()(struct usb_serial_port *)’ [-Werror=incompatible-pointer-types]
773 | .port_remove = Gobi_portremove,
| ^~~~~~~~~~~~~~~
/var/lib/dkms/SierraLinuxQMIdrivers/S2.42N2.64/build/GobiSerial/GobiSerial.c:773:27: note: (near initialization for ‘gGobiDevice.port_remove’)
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:249: /var/lib/dkms/SierraLinuxQMIdrivers/S2.42N2.64/build/GobiSerial/GobiSerial.o] Error 1
make[1]: *** [Makefile:1851: /var/lib/dkms/SierraLinuxQMIdrivers/S2.42N2.64/build/GobiSerial] Error 2
make[1]: Leaving directory ‘/usr/src/kernels/5.19.8-200.fc36.x86_64’
make: *** [Makefile:25: all] Error 2
make: Leaving directory ‘/var/lib/dkms/SierraLinuxQMIdrivers/S2.42N2.64/build/GobiSerial’

I’ve already tried disabling [Werror] in dkms but I can’t find any -Werror flags in the Makefiles
Any Ideas on how to solve this?

Does this help