Ext4 support on WP76xx

Hello

I’m trying to mount an ext4 formatted SD Card and I get:

mount: unknown filesystem type 'ext4'

And sure enough ext4 is not supported

# cat /proc/filesystems
nodev   sysfs
nodev   rootfs
nodev   ramfs
nodev   bdev
nodev   proc
nodev   cgroup
nodev   cpuset
nodev   tmpfs
nodev   devtmpfs
nodev   debugfs
nodev   securityfs
nodev   sockfs
nodev   pipefs
nodev   rpc_pipefs
nodev   configfs
nodev   devpts
        squashfs
        vfat
nodev   nfs
nodev   nfs4
nodev   overlay
nodev   mqueue
nodev   smackfs
nodev   mtd_inodefs
nodev   ubifs
nodev   functionfs

It is present in /etc/filesystems however

# cat /etc/filesystems
ext4
ext3
ext2
vfat
fat
btrfs
minix
*

How do I enable Ext4 filesystem support on a WP76xx module?

So far I’ve tried adding it with IMAGE_FSTYPES += " ext4" in my image.inc file but doesn’t appear to do anything.

Thanks!

Does this help?

Thanks, though not quite, I am able to use mkfs.ext4 and format the SD card but my issue is mounting it. I can read/write it ok on a desktop machine so can confirm it’s correctly formatted and partitioned.

I just see the menuconfig on FW R13 yocto source, I saw there is EXT4 related flag in it, you can try to enable it.

# cd yocto
# make dev
build_bin# bitbake linux-quic -c menuconfig

Thanks, however due to the way we’ve set our workspace, I can’t use bitbake or not easily at least. Can you advice what changes the flag does or which packages I need to add?

I never tried before, but I saw that inside meunuconfig search, there is ext4 related flag, you can see here:
ext4.txt (7.1 KB)

so it worths a try to add those flags in menuconfig

I just tried to enable in menuconfig
filesystem → The Extended 4 (ext4) filesystem

After that recompile the yocto image, now I can see:

root@swi-mdm9x28-wp:~# cat /proc/filesystems
nodev   sysfs
nodev   rootfs
nodev   ramfs
nodev   bdev
nodev   proc
nodev   cgroup
nodev   cpuset
nodev   tmpfs
nodev   devtmpfs
nodev   debugfs
nodev   securityfs
nodev   sockfs
nodev   pipefs
nodev   rpc_pipefs
nodev   configfs
nodev   devpts
        ext3
        ext2
        ext4
        squashfs
        vfat
nodev   nfs
nodev   nfs4
nodev   overlay
nodev   mqueue
nodev   smackfs
nodev   mtd_inodefs
nodev   ubifs
nodev   functionfs
root@swi-mdm9x28-wp:~# cat /etc/filesystems
ext4
ext3
ext2
vfat
fat
btrfs
minix
*
root@swi-mdm9x28-wp:~# cm info
Device:                        WP7607-1
IMEI:                          359780080500170
IMEISV:                        6
FSN:                           V2842570321010
Firmware Version:              SWI9X07Y_02.28.03.03 000000 jenki[  241.643193] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x0c1300c8 OPER:0x00000090
ns 2019/05/21 03:33:04
Bootloader Version:            SWI9X07Y_[  241.662671] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x0c1300c8 OPER:0x00000090
02.28.03.03 000000 jenkins 2019/05/21 03:33:04
MCU Version:                   002.011
PRI Part Number (PN):          9908645
PRI Revision:                  001.001
Carrier PRI Name:              GENERIC
Carrier PRI Revision:          002.068_000
SKU:                           1104186
Last Reset Cause:              Reset, User Requested
Resets Count:                  Expected: 148    Unexpected: 0
root@swi-mdm9x28-wp:~#

Thanks, that’s what I’m after. Is there a way to enable the feature without using menuconfig and by directly modifying the kernel settings?

You can go to yocto/kernel/arch/arm/configs/mdm9607_defconfig
and add CONFIG_EXT4_FS=y

After that you can build the yocto image and try.

Sorry, should’ve clarified. I already tried adding to mdm9607_defconfig but it didn’t work

Edit:
after the change the config option is still unset:

# zcat /proc/config.gz | grep CONFIG_EXT4_FS
# CONFIG_EXT4_FS is not set

Appologies again, found a typo in my changes. It works now