"+++" escape sequence in v24 data mode


#1

Hello!
My application automatically switch Fastrack Supreme into v24 data mode. When I use hyperterminal, I can send “+++” to switch to AT mode, but in M2M remote shell I cannot do this, because any sequence ends with “carriage return” character.


#2

The M2M Studio shell is currently designed only for AT commands usage. It is planned to make this evolving in future releases, thanks to new features in Target Management.


#3

That is very disappointing! :frowning:

Surely the whole point of a modem is to be able to transfer data?! :unamused:

Good! :slight_smile:

Please be sure to support the existing TMT feature allowing the data to “pass-through” to an external “application”:

See: viewtopic.php?f=53&t=2509&p=11123&hilit=external+com#p11123

It would also be really useful to be able to do this to a “virtual” port - so that an application on the same PC could connect direct to the data “flow” without having to go via a physical COM port connection…


#4

like with MuxConfTool :slight_smile:


#5

As you may have guessed, I’ve never used the MuxConfTool - I’m increasingly getting the feeling that I should look into it…


#6

Yes, i can recommend it.
though (as with most wavecom software) it has a bit of a learning curve,
but as is has only one purpouse, it hasn’t got that many options to get confusseld about :smiley:


#7

Being able to issue (pause)"+++" (pause) from the Remote Shell would be very useful!

Also being able to issue control characters (e.g. ETX)

And also being able to define a block of hex to transmit as data…

Is there any reason why issuing the escape sequence from Hyperterminal would fail to return the device to command mode?


#8

Yes, the M2MStudio really hasn’t come anywhere near providing equivalent functionality to the old TMT yet… :frowning:

I think an application can choose to ignore the escape request?