Errors with FX30 application

I have an FX30 and I’m having lots of issues. Mainly due to the lack of clear documentation, or out-dated documentation.

  1. When I use the latest dev studio (5.3.1) to compile and deploy an application for the FX30 with the latest firmware, I get the following message:
    Legato Framework version used in application (16.10.3) and running on the device (16.10.1.m3 j5d280affleaa96ea13459ca6effa50c5_modified) are not the same. Continue the installation anyway?

For simple programs (helloWorld) the program runs fine. For more complicated programs (modemDemo) the installation works, but the application crashes. I don’t know if this related to the

  1. So I tried building my own legato framework from source, for CLI development (which I would prefer). But the documentation is very convoluted here. Does someone have some clear steps for compiling the legato framework that works for the FX30? I’ve been here and tried these steps, but not much luck.

hi there,
I apologize for the confusion regarding the latest build and DevStudio.

Please see benrey’s post here:


Thanks Chris.

After the following mistakes:

  • Not running Ubuntu 16.04, but 18.04
  • Executing step 1, then 2 actually makes your build fail. Once it fails you need to do make clean. You should first install the toolchain (step 2), then compile the framework (step 1).

I was able to compile using make wp85.

However, once I added the folders to the Developer Studio I was unable to use the packages. The packages show like the screenshot below.

Any ideas?

For my reference (and others). These are the CLI commands I used to build the framework for source:

# Install dependancies
apt update && apt dist-upgrade -y 
apt-get install -y build-essential python python-jinja2 cmake git subversion libsdl-dev diffstat texinfo gawk chrpath wget cpio vim zsh bash ninja-build screen sshpass bc python-git unzip libxml2-utils wget

# Toolchain
chmod u+x 

# Application Framework
wget -O legato-16.10.1.m3.tar.bz2
tar xjf legato-16.10.1.m3.tar.bz2 
cd legato-16.10.1.m3


make localhost
make wp85

UPDATE: Updated the above “script” to add WP85_TOOLCHAIN_DIR and WP85_TOOLCHAIN_PREFIX


did you read the in the legato directory ?
I do not see (regarding your commands) where are set the WP85_TOOLCHAIN_DIR and WP85_TOOLCHAIN_PREFIX env variables.

You can also check if the FX30 / WP85XX are set in the module selection:

This can be configured in window/preferences/Developper Studio/Module

Thanks Benrey. Yes, I had added the env vars, just forgot to list them.

The issue is that the Compiler and Legato AF do no appear in the “Target Platform”. Oh, well I will continue with the CLI builds.

I’ve had more success with getting Rust going and this may work better for me. Since I don’t need a lot of what the Legato framework offers.

@dpochet, are you able to help out with this issue?

Hi @cchenry

I’m working with a FX30 with Legato, but I have some problems.

I’m using a FX30 Eth 3G and Developer Studio, Legato for WP85/WP75 R17.

The firmware versión of FX30 is

The Serial Number is LL832400291310

The problem is when I install the hello world app, or any application show the message

"Legato Framework version used in application (18.06.4) and running on the device (16.10.1_f8947ec5fd286f5b9d2c25ebb9ad81a4) are not the same. Continue the installation anyway?

If I accept, send the application and after that show the messages

“Application avcService has crashed 1 time”

“Application HelloWorld has crashed 2 times”

I tried everything you suggest up, I could not solve the problem.

Hi there,
You need to use the Legato 16.10.1 toolchain to build your application.

Thanks a lot, It’s working now, I hope I have no more problems.