EM919X/EM7690 not recognised in Router We826

I have the Router We826 running with Sierra EM7565. Then I am looking into building a router that has good carrier aggregation and band support. EM7690 is the one I am looking into.
I put the EM7690 into the Router and also ported the SDK into openwrt linux driver as EM7690 driver openwrt

But the EM7689 even cannot be recognized.
kernellog_em7690_better.txt (20.6 KB)

Any help or a point in the right direction would be highly appreciated.

Does your EM7690 works in Windows platform?
you can try the latest USB driver in linux here:

Can you also remove the “sierra” and “sierra_net” driver as it should use qcserial and cdc_mbim driver?

[   21.417520] usbcore: registered new interface driver sierra
[   21.423290] usbserial: USB Serial support registered for Sierra USB modem
[   21.434972] usbcore: registered new interface driver sierra_net

Thank you @jyijyi .
I have not tried on Windows yet.
I could see the sierra and sierra_net in EM7565 but EM7565 works properly.
I will try to disable those sierra and let see.

I tried em9190 with the mbpl r23 usb driver on ubuntu 18 pc, it is working fine

@jyijyi what USB adapter that you use?

I’ve checked the spec and can see that it is required the interface selection

It used usb type c in the dev kit

@jyijyi I see.

Maybe the card has not been wired the PCIE_DIS to 1.8V. That is why there is no USB detection in the kernel log as well.