Can't detect EM7565

I have managed to break my Sierra Wireless EM7565 Modem, not sure exactly of the root cause, although I was power cycling it quite regularly. Before the device was showing up with process ID of 0x9090/bootmode, however now I cannot see it at all, i.e. in /dev on my Linux machine, the command ‘lsusb’ is not showing any device. How would I recover it?
Any help would be greatly appreciated thanks.

Hi @tmiller,
Welcome you to our community!
Have you installed the MBPL driver?
If not, please install the latest MBPL driver following the link below:
Then unplug the module and plug it back in.
Do the issue still happens in this case?


Hi jerdung,

Thank you for your reply.

Just to confirm, which of these files should I download?

I did download the MBPL_DRIVERS_R28_ENG1-bin.tar.gz file and found my operating system but my kernel version is not listed.
I am trying to get the modem working on both of my systems, one running Ubuntu Server 22.04 LTS, Kernel 5.15.0-46 and Debian 9, Kernel 4.19.94, neither of which kernels are listed in that file.
I tried to load the drivers for the Ubuntu_x64\5.3.0-55-generic kernel into my Ubuntu system but it returned a “Exec format error” when I tried to load it in with modprobe.
It is impractical for me to change the kernel on my systems as there has been a lot of work done on them so far.

Hi @tmiller ,
If you are using a USB cable for the module, you should download the MBPL_DRIVERS_R28_ENG1-usb-src.tar file, then extract and install it according to the instructions in the “Readme.txt” file contained therein.