EM7565 wrong USBCOMP Command sent - did i brick it?


#1

Hello guys,

i have just signed up because of the following problem.

I configured some EM7455 modules to use MBIM in windows10 with the following commands.

  1. AT!ENTERCND=“A710”
  2. AT!USBCOMP=1,1,100D
  3. AT!RESET

Unfortunately i have sent the same command to one EM7565 Module.
The result is my windows pc does no more recognize the module correct.
It says no driver found… i have tried the USBCOMP parameter of the driver installer but it seems also not to work.

When using linux i still get the device listed in lsusb and i do get the nemea and the diagnostic port but i cannot find a port to send AT commands. (/dev/ttyUSB2 is missing)
I have tried this solution but it did not work. It seems like another type of issue.

Is there any solution i can try by myself or did i brick the module :confused:

Any help is very appreciated.
Thanks in advance and best regards, Alex


#2

User @westrem had the same issue, and solved it using the hint here: https://forums.whirlpool.net.au/forum-replies.cfm?r=55565685#r55565685

Read my comments there and compare with your lsusb output. Or post it here if you want me to take a look.

IIUC the main difference between the modes is that the MBIM function is using interfaces 0 and 1 and the serial functions just follow on. The default serial driver (qcserial) is not prepared for that. But the option driver is flexible enough to be used for a “rescue”


#3

Thank you so much for your fast response and the hint to your solution.
It worked exactly like described in the post for me as well.

  • modprobe option
  • echo 1199 9091 > /sys/bus/usb-serial/drivers/option1/new_id
  • and then connect to /dev/ttyUSB0 :slight_smile:

You are awesome!!!
Best regards, Alex