EM7565 no connection


#1

I use debian 9.6 and cannot get the EM7565 running. Any idea?

root@Atro:/home/lars# usb-devices

T: Bus=01 Lev=01 Prnt=01 Port=05 Cnt=01 Dev#= 2 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=1199 ProdID=9091 Rev=00.06
S: Manufacturer=Sierra Wireless, Incorporated
S: Product=Sierra Wireless EM7565 Qualcomm® Snapdragon™ X16 LTE-A
S: SerialNumber=UF82338945021037
C: #Ifs= 4 Cfg#= 1 Atr=a0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=qcserial
I: If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=qcserial
I: If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=qcserial
I: If#= 8 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=qmi_wwan


#2

you should use GobiSerial and GobiNet for the driver.


#3

@Atro,

As jyijyi has said you need to use the GobiSerial and GobiNet drivers which are Sierra’s own device drivers for our units. While the open source ones can work well (which your system can be seen to be invoking) for some customers they can also cause problems, additionally we cannot support you when using them (as they are open source).

The below document discusses how to build them into your system.

SWI Technical Note - IP connectivity using RMNet enabled modules and AT commands.docx (338.9 KB)

The link to the latest is here.

https://source.sierrawireless.com/resources/airprime/software/usb-drivers-linux-qmi-software-s2,-d-,35n2,-d-,54/

Regards

Matt


#4

Thank your for your help and the information.
I am a linux newbie, i tried but there are several problems.
The building drivers.txt uses

/lib/modules/4.15.0-29-generic/build

but I found in my debian 9.6 only

/lib/modules/4.9.-8-amd64

and no “build” folder


I found this in the web:

I tried the command:

diff --git a/drivers/usb/serial/qcserial.c b/drivers/usb/serial/qcserial.c
index 9f9d3a9..55a8fb2 100644
--- a/drivers/usb/serial/qcserial.c
+++ b/drivers/usb/serial/qcserial.c

but have error that “–git” is unkwon

diff and git is installed.

Any idea?


#5

Why are you still compiling qcserial?
As said before, you should use GobiSerial and GobiNet.
I tried to compile GobiSerial S2.31 in Debian 9.4, no problem is found.


#6

@Atro,

Running along with jyijyi here, if you want to use qcserial then yes you will need to use a really up to date qcserial driver as the module is quite new. Also the qcserial driver while it will work it is not the recommended driver to use, you need to use the drivers as I gave above.

Regards

Matt


#7

Short to my history:
I bought Lenovo Thinkpad X1 Carbon 6th with Fibocom 850GL. Windows WWAN work preinstalled. But I want to try Linux, so I am a Linux beginner. I read that Fibocom 850 do not work with Linux on my laptop. I read on reddit

" TPader
t25, x220, x1c g3, t470p etc.1 point · 29 days ago
Regarding Linux and Sierra em7565:

EM7565 is supported in Debian stable (kernel package version 4.9.82-1+deb9u2). No additional drivers. Then use ModemManager."

So I thought I can install the card and use ModemManager and that is all. I now tried Xubuntu, Debian 9.6 and Buster Alpha 4. But always same problem that it cannot be enabled.

I thank you for your help. I tried yesterday several hours the GobiSerial, but I have too less skills on linux to create the driver.

But if you say that is the only possible option for me than I thank you for this help and I now try this again and report my problems.


#8

I also find this post:

“The EM7565 is now (with kernel package version 4.9.82-1+deb9u2) supported in Debian stable. No additional drivers or hacks are necessary. The only package you need is modemmanager.”

Does this mean that they also need to use GobiSerial? For that sounds like “do nothing” it work out of the box???


#9

@Atro,

Since you are new to the game I will elaborate.

PC OEM’s (like Dell) will buy a module from companies like Sierra, Fibocom, etc, they will then lock the hardware down quite hard within the BIOS to work only with what they have shipped the laptop with to stop people doing what you are trying for warranty reasons, etc. Only way to use a different modem is to plug it into one of the external USB ports using a development kit.

Not a lot we can do to help.

Regards

Matt


#10

Thank you Matt,

you mean, I do not need to try the gobiserial, it cannot help in my case? Did I understand you correct?

BR
Atro


#11

@Atro,

No what I am saying is that if you are using the onboard M.2 slot then anything could be happening with the unit at a really low level (below Linux) that we have no knowledge or control over. You can try the Gobi drivers and it might work but we cannot support you given you are sticking the unit into the onboard slot.

Regards

Matt


#12

Yes Matt, I understand. Some people say that the Em7565 is not blacklisted in the X1 Carbon 6th Bios and that it can work, that is the reason why I try it.

Can you please check if I did the first things correct:

System:
atro@debian:~$ uname -a
Linux debian 4.19.0-1-amd64 #1 SMP Debian 4.19.12-1 (2018-12-22) x86_64 GNU/Linux

Step 1:
deleted qcserial.ko and qmi_wwan.ko
than reboot

Step 2:
I unzip the package you gave me.
I created the desktop folders “QMI_drivers” and “SierraLinuxQMIdriversS2.34N2.53”
I copied the package content to the new folders.

Step 3: Starting with “Building Drivers”
open terminal and cd = root@debian:/home/atro/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.35N2.54/GobiSerial#

Step 4:
In the “building text” i replace the word “Desktop” with “Schreibtisch”

Than I have this code:
sudo make rm -rf *.o ~ core .depend ..cmd *.ko .mod.c .tmp_versions Module. modules.order .cache.mk make -C /lib/modules/4.15.0-29-generic/build M=/home/ubuntu/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.34N2.53/GobiSerial modules make[1]: Entering directory ‘/usr/src/linux-headers-4.15.0-29-generic’ CC [M] /home/ubuntu/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.34N2.53/GobiSerial/GobiSerial.o /home/ubuntu/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.34N2.53/GobiSerial/GobiSerial.c:231:2: warning: #warning “Assuming disc_mutex is locked external to the module” [-Wcpp] #warning “Assuming disc_mutex is locked external to the module” ^~~~~~~ Building modules, stage 2. MODPOST 1 modules CC /home/ubuntu/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.34N2.53/GobiSerial/GobiSerial.mod.o LD [M] /home/ubuntu/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.34N2.53/GobiSerial/GobiSerial.ko make[1]: Leaving directory ‘/usr/src/linux-headers-4.15.0-29-generic’

I get this error:
make: *** /lib/modules/4.15.0-29-generic/build: not found

Do I need to change the patch to “/lib/modules/4.19.0-1-amd64” (there is no build folder in my modules folder!) ?

When I do this and enter this code:

sudo make rm -rf *.o ~ core .depend ..cmd *.ko .mod.c .tmp_versions Module. modules.order .cache.mk make -C /lib/modules/4.19.0-1-amd64 M=/home/ubuntu/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.34N2.53/GobiSerial modules make[1]: Entering directory '/usr/src/linux-headers-4.19.0-1-amd64 CC [M] /home/ubuntu/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.34N2.53/GobiSerial/GobiSerial.o /home/ubuntu/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.34N2.53/GobiSerial/GobiSerial.c:231:2: warning: #warning “Assuming disc_mutex is locked external to the module” [-Wcpp] #warning “Assuming disc_mutex is locked external to the module” ^~~~~~~ Building modules, stage 2. MODPOST 1 modules CC /home/ubuntu/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.34N2.53/GobiSerial/GobiSerial.mod.o LD [M] /home/ubuntu/Schreibtisch/QMI_drivers/SierraLinuxQMIdriversS2.34N2.53/S2.34N2.53/GobiSerial/GobiSerial.ko make[1]: Leaving directory ‘/usr/src/linux-headers-4.19.0-1-amd64’

I get no error message, only a “>”
Does this mean it was succesful ?

Thank you

BR
Atro


#13

I tried more, but it is unpossible for me.

I find this post:

A user has same X1C6 Bios 1.34 and use the Sierra 7455 / 7565 and Linux.

They said it work after turn off the card low power mode:

Hopefully, he found out how to resolve this by following these commands :


  • AT!ENTERCND=“A710”
  • AT!PCOFFEN=2
  • AT!RESET

And voilà, the Cellular option should now be turned on, and the EM7455 pulled from my Dell is now fully working in my Thinkpad X1 Carbon 6th Gen.

And by the way, if anyone want to use his Sierra Wireless EM7455 pulled from a Dell system, or pick a generic one, follow these steps:

  • AT!ENTERCND=“A710”
  • AT!USBVID=1199
  • AT!USBPID=9079,9078
  • AT!USBPRODUCT=“Sierra Wireless EM7455 Qualcomm Snapdragon X7 LTE-A”
  • AT!PRIID=“9904609”,“002.026”,“Lenovo-Storm”
  • AT!PCOFFEN=2
  • AT!RESET

Once reset, you should install the Lenovo Sierra Wireless Driver, and reboot your windows. Everything should work from now on.

You think this is a possible solution?
On windows it is putty, can you recommend me a program for linux to establish a connection to the wwan m.2 card?


#14

@Atro,

The standard terminal program in Linux is minicom.

Regards

Matt


#15

I now got the modem EM7565 m.2 running with Lenovo X1 Carbon 6th (Bios 1.34) and Linux without the Gobi stuff.

You need to change several parameter on the modem. For example the low power mode AT+CFUN=0 to AT+CFUN=1

more details:

and

Many people have this problem, but Lenovo do not offer a bios update to change the setting for the installed Fibocom between pci-e and usb for Linux use.
So some people try Sierra but it is not easy to get it working.
Its a pity that there are no workarounds for this problem, e.x. a small program that automatically change the modem settings. It seems the main problem is that the modem is in low power mode and that is the reason why it cannot start.
For all with this problem check the reddit thread.


#16

Can you help me with question to the backup.
The changed settings of my m.2 modem EM7565 are saved with AT!NVBACKUP=3,OK
My question is now, when maybe my system crash and I need to install linux again, does the modem automatically boot with the last settings or does it boot with “standard” settings and I have to load the backup “OK” I want ?

thx


#17

@Atro,

A system crash should in theory not affect the unit since as far as it is concerned it should just be the host disappearing.

Regards

Matt


#18

Matt, I mean no Crash and reboot, I mean a new installation of the OS.
For example linux new installation.


#19

@Atro,

I would not expect it to change although you can test this by saving a config in one system and then plugging it into another system. You need to make sure that what it is saving is what you want, the unit is constantly saving, over writing, deleting, etc a lot of parameters (some of which are visible to the application others are not).

Regards

Matt