EM7565 Firmware Upgrade

Hi , We are using EM7565 on Linux/Debian system ,
Current FirmwareVersion SWI9X50C 1.0 Release 6 (2017/09/29 05:54:26 )

As part of issues faced during enabling CA, during execution of commands like
Error - LTECA not implemented

Suspecting this to be due to Very Old firmware,
We tried upgrading the FW version to latest SWI9X50C 1.0 Release 13 (2019/02/26 20:33:22)
Error Faced - root@abc:~# sudo qmi-firmware-update --update -d 1199:9091 --device-open-mbim SWI9X50C_01.09.04.00.cwe SWI9X50C_01.09.04.00_GENERIC_002.019_000.nvu
loading device information before the update…
setting firmware preference:
firmware version: ‘’
config version: ‘002.019_000’
carrier: ‘GENERIC’
rebooting in download mode…
download mode detected
error: error creating device: HDLC trailing control character not found

Error Faced

Is the modem connected to a USB3 port? If so, then this is probably the QTI9X50-837 bug fixed in release 9.

But there’s a chicken and egg problem there of course. Known workarounds are using Windows to upgrade, or temporarily disabling USB3. If the modem is in an external USB adapter, then the workaround is as simple as using a USB2 cable while upgrading from realeases prior to 9.

Temporarily setting AT!USBSPEED=0 might also work, I guess? But only if that setting is respected by the boot loader, and in particular the old and buggy boot loader. I don’t know. Haven’t tried. Anyone who has?

Hi @vikksviking
Have you tried with the Linux QMI SDK lite-fw-download tool? For the open source tool, you can try with device-open-qmi option. I’m not very familiar with it. You can check the modem’s USB composition with AT!USBCOMP command. Please refer the AT commands guide.
What is the ATI on your modem?


Thanks !! Modem is attached as USB2.0. Currently we are using the below for upgrade

sudo qmi-firmware-update --update -d 1199:9091 --device-open-mbim SWI9X50C_01.09.04.00.cwe SWI9X50C_01.09.04.00_GENERIC_002.019_000.nvu

We will try the options suggested.


Hi @dl5162
Thanks !! Yes the modem connected as USB3.0 but we still tried using the Linux-QMI-SDK-Lite fw tool, the download reaches to the last step but it gets stuck after that. Followed the URL

USBSPEED=0 is not working. We tried on Linux Machine (Ubuntu and Debian) , same issue on both.
Any other option, can you please suggest some adapter (M.2 to USB2) ? Noticed LTECA command also not working

Thanks !!

Any m.2 to USB adapter will work, even the USB3 ones, as long as you use a USB2 cable. I did just that., after first trying and failing with the USB3 cable. I described the whole process in this post:

Please note that you need libqmi git master version for qmi-firmware-update to work on the EM7565, there is no stable release (yet) with the EM7565 firmware upgrade support yet.

The " error: error creating device: HDLC trailing control character not found" error is because you’re using an older libqmi version.