EM7421 Unable to find satellites

Unable to configure the device to work with GPS.
The driver was installed from this website and there are no errors during device detection.
ModemManager is either removed or not in use.
In devices /dev/ttyUSB0, /dev/ttyUSB1, /dev/ttyUSB2.
Please help with identifying the problem.
Thank you in advance.

Did you connect gps anteanna?
Did you check with AT command?


Trying to connect to the terminal for command input, but the field is empty and I can’t input any text.

How about other port?
Do you install the correct MBPL usb driver?

Do you try with windows?

These drivers were used.
It works under Windows.
Assembled from source code

Then you can try those AT command in windows and see if it can view satellite

Yes, very well, we will check this.
However, it is necessary for it to work on Linux.

Does it work for using minicom on ttyUSB2 or ttyUSB0?
have you tried Ubuntu 18?

Yes, I was able to send AT commands via minicom using ttyUSB0.

However, as a result, it still doesn’t detect any satellites.

didn’t it show there is satellite in AT!GPSSATINFO?
Did you see any NMEA frame in /dev/ttyUSB1?

No, there were no new data appearing in ttyUSB1.

you can try:

and see if within those 255 seconds, any NMEA frame coming out from /dev/ttyUSB1?

Снимок экрана от 2024-03-20 10-19-36
This did not help.

how about this?


Снимок экрана от 2024-03-20 10-47-19

Okay, now we are seeing this output. However, the data is still not visible in cgps.
AT!GPSFIX=1,255,1000 - We also entered it.

then what is the problem?
your application?
NMEA frame?

The problem is that in GPS programs, there is no information about the satellites.
The module’s operation is not visible, and there is no data.
The programs used are CGPS and GPSMON and GPSD

then why NMEA frame is showing satellite but your application cannot view it?

What program would you recommend for obtaining satellite data?
So that it is clearly visible that the GPS module is working correctly?

i don’t know, i never used any gps program

You can have a look on the raw NMEA frame and decode it and see why your program cannot see those satellite