DS Legato Application Framework download?


As per daav’s suggestion here, I’ve downloaded the updates to DS from the update site. Actually, I created a new install from the zip file previously downloaded, and done a complete clean update.

Now, when I try to create a new Legato Application Project, I get to the wizard page shown below:

I’ve been to the package import wizard, and the only site available is the default OpenAT repository - updatesite.sierrawireless.com/packages/OpenAT - which doesn’t contain any packages for the Legato.

Can someone please point me to the right Package repository to download Legato packages so I can finish creating the project.

Ta. Getting there …

ciao, Dave

Hey Dave,

In your legato folder, make sure that you have Legato built for the AR7.

Then in DevStudio you need to open the packages manager perspective. Go to WIndow/Open Perspective/Other…

Then click on “Packages Manager” and click OK.

Once that’s done, right click in the Avaiable Packages box and select “Add new repository.” In the repository path group box click Folder, then click the “…” button and find your Legato instalation. Click OK and you should now have a Legato package ready to install.

Right click on the Legato package and select “Install Selected Packages.” Once that’s done, you can fire up the Legato project wizard and you’ll be able to select a framework to build against.


Hi Kelly,

Getting close … but still not quite there.

First, I’m running legato-AlphaB-r1. Is there an update? If so, where can I get it please?

I’ve run the make ; make ar7; make docs in the legato application directory as you suggested. They all appear to complete without errors. Below is a screenshot of the end of the make ar7 compile.

Which looks to me like it completed successfully.

Now when I go to DS and add the new repository, DS indicates that there is indeed a repository at the directory location, and that the package Legato Application Framework (0.0.0) is available. I can select install, but then the install fails with the following message:

Which looks to me as if the make process has failed to build a component of the install package.

Am I running the latest version of the Legato framework?
What have I missed? I’ve run the Legato environment setup (otherwise the AR7 toolchain wouldn’t be found correctly).

Almost there…

ciao, Dave

Hello Dave,

Looks like you are missing a package file. Try creating a file called “package.properties” in the Legato root.

Then write the following into it:


Then try installing the package again.


Hi Kelly,

Closer still…

I now have a sane version number against the Legato framework in the Package Manager, but the package is still giving me the same error - bad plugin - when I try to install it. I’ve captured the error in the screenshot below:

I’ve also done a make clean; make ar7 on the legato install directory (and checked that the package file is still there!), but still no joy.

ciao, Dave

You’re pretty close to the end :wink:
DS 3.0 is compatible with the incoming next release of the Legato framework, and the one you have is missing some stuff:
DS is expecting a tar archive to be present in the build folder, necessary to upgrade the Legato framework on the device from DS.
This tar archive should be found at /build/<ar7|wp7>/legato-runtime.tar and it should contain what’s in the staging directory.
The creation of this tar archive is automated in latest version, but not in yours.
You should try to create it manually (even a fake one, if you don’t plan to use the Legato framework device update facility from DS) to let DS install the package.


We’re away - “Hello World” has compiled (after using Kelly’s hint about manually editing the .adef file here).

Thanks to everyone for the assistance - especially Kelly & daav.

Now to see what I can break next :smiley:

Thanks to everyone.

ciao, Dave