Disable mssfix/fragment for OpenVPN connection

Hi all, I have a RV55 and having a difficult time working with my company VPN.

The issue is that the openvpn client on the RV55 has no option to disable “mssfix” and “fragment” (defaulting to 1400 and 1300, respectively). The VPN server does not specify a fragment size, which causes the following error message:

Mar 17 13:10:23 err openvpn-1[1937]: FRAG_IN error flags=0xfa2a187b: FRAG_TEST not implemented

This results in a an established VPN connection with an unusable link.

I can also see similar MTU-related warnings that would benefit from a more configurable openvpn configuration:

Mar 17 13:11:23 warning openvpn-1[1937]: WARNING: ‘link-mtu’ is used inconsistently, local=‘link-mtu 1562’, remote=‘link-mtu 1558’
Mar 17 13:11:23 warning openvpn-1[1937]: WARNING: ‘mtu-dynamic’ is present in local config but missing in remote config, local=‘mtu-dynamic’

Is it possible to edit the openvpn configuration manually outside of AceManager to remove these settings?


  1. Changing the server settings is not an option


I see another individual on this forum has experienced the same issue.

The solution is setting mssfix and fragment to 0.