Connecting MC-7430 to system (CentOS-8)

Hi,
I want to connect MC-7430 to my PC which has Centos-8 as operating system. I have done it on Windows which was easy and then used some application for AT commands but I dont know how to make it work on Centos. Can anyone help me with this? is there any guide that I can follow?

have you installed the MBPL USB driver?
https://source.sierrawireless.com/resources/airprime/software/mbpl/mbpl-software-latest/#sthash.ZXRwiiKx.dpbs

have you tried with minicom to enter AT command?

I was trying to connect to modem today. I am using Virtual machine. I am loosing connection to my USB again and again. Finally it is a bit stable. I can see in usb0,1,2 are mount. i went to minicom -s , under serial port setup changed serial device to /dev/ttyUSB and SW flow to yes after saving it gets into minicom but I cant do anything in there. am I on the right path?

is it the same for all three ports with the MBPL USB driver?
If yes, then maybe your module is dead

Yes, but on window it is working fine. I can see all ports and send commands to AT ports but just on the CentOS-7 (VM) it doesn’t want to do anything in minicom. I am trying another module MC7700 now and I can see it under the usb-devices
image
can see its mounted too


Still on Minicom I dont get anything

I don’t see such problem in Ubuntu 16,18,20

I am not expert of CentOS, probably you need to go to other CentOS forum to ask

Hi Jyijyi, I can now get to minicom but my modem wont connect. I changed it from unmanaged to manage and then the status was unavailable. when I set the link to up. It comes up as disconnected. also it says plugin missing. Can you help me with this
image

didn’t you should test on MC7430?


I did try different modules. for all it is the same. On MC7340 I am seeing something different. it comes up with two MAC Addresses

did you see problem in Ubuntu 18?
I don’t know what is the meaning of “plugin missing”…

No, Haven’t tried Ubuntu, only working on CentOS. I’ll try that with Ubuntu soon