Can't upgrade FXT009 from 7.45.1 to 7.52


I am trying to update a FXT009 modem from 7.45.1 to 7.52 using the 15-pin Sub-D Serial Interface. I am using Windows 7 32-bit.

It doesn’t work in Target Management of Developer Studio 3.3 because 7.45.1 firmware doesn’t support at+wopen=9.

So I tried it using a communications program and Xmodem. The bootloader update (dwl.dwl) was ok but it fails 2/3 of the way into the main firmware download (R7.52.0_fxt009.dwl) at about
958 Kbytes of the total size of 1.42 Mbytes. The download is cancelled by the Receiver (ie the FXT009).
I repeated it several more times and the same thing happened.

Procedure I followed was: … D=&aid=487

I managed to get modem back to working order by downloading 7.45.1 bootloader and firmware again.

I also tried to upgrade to 7.47.4 (dwl.dwl and R7.47.4_fxt009.dwl) and this was ok but again when I tried to upgrade to 7.52 it failed in the same way as before.

I then tried to update another 7.45.1 FXT009 modem to 7.52 firmware and the same problem occurred.

Has anyone had a similar experience or can someone suggest a workaround?

Best Regards
Tom Paasuke


My experience is that you have to do the upgrades in steps … 7.45 to 7.47 to 7.50 (?) Then to 7.52.

There are some release notes available with the firmware bundles. Make sure you read them carefully, as I seem to recall that you had to update the boot loader during one of the upgrade steps. Unfortunately, I don’t have the notes readily available.

Also as the firmware install is failing, I suspect that the memory setup for the A&D module needs to be changed to allow a larger area for firmware downloads. Use AT+WOPEN to determine the sizes of the flash memory partitions. You can also change the size of the A&D ‘partition’ using AT+WOPEN.

Finally, if you get really stuck, there is an application called DWLWin that can reflash the device using a special install bundle with a wpk extension. You need to talk to your distributor to get the appropriate firmware bundles for your device.

Ciao, Dave

Hi Dave,

I managed to find only R7.51 firmware (couldn’t find 7.50.? for FX009) on sierra wireless website but not the matching bootloader (dwl.dwl). … kage-7_51/

When I tried to update the firmware to 7.51 without downloading the matching bootloader it fails immediately.

They are in Open AT Application Framework 2.51 but I can’t find a download for this, only release notes.

Can someone send me a web location or repository that I can download them from or send them to me?

Best Regards

Hi Dave,

Thanks, I have now solved the issue.

Someone provided me with 7.51 FXT009 firmware.

At your suggestion I ran AT+WOPEN=4 to delete my OAT application first (I was already running AT+WOPEN=3) and I was able to go from 7.47.4 to 7.51. I xmodem downloaded w.dwl, then dwl.dwl and then finally the 7.51 FXT009 firmware.
I then upgraded OK from 7.51 to 7.52.

AT+WOPEN=4 may have been the command that fixed my problem or I may have needed the 7.51 upgrade step or I may have needed both.

Best Regards