Can not get ED_OK_FILE_TRANSFERRED


#1

hi.
i use V3.10 OpenAT library and i use the following operations to perform the dota I. but i cant even download the file from ftp server
İ use the ed library FTP socket to download the file.

  1. Prepare AD cell of unknown size
  2. Set all GPRS parameters
  3. Get an IP address
  4. Set FTP parameters for FTP GET function
  5. Make a FTP GET
  6. Wait for message ED_OK_FILE_TRANSFERRED
    But can not get the ED_OK_FILE_TRANSFERRED message. The application reads for some data from server, first it reads for some size then it freezes and begins waiting . Then it waits for sometime and ftp connection is closed.
    when i try to monitor this i see the messages like

reads
reads
reads
reads



reads

then it waits for several minutes until it loses the connection. why cant i get the ED_OK_FILE_TRANSFERRED event? why cant it reads all the file? anyone knows?


#2

i solved it by setting the ftpmode parameter to 0 which is active mode. After doing this it sent the ED_OK_FILE_TRANSFERRED message. i will look for the difference between active and passive mode later because now i have a new problem.
After i got the ED_OK_FILE_TRANSFERRED message i run adl_adInstall function to install the file downloaded. But it gives me error message. Any idea?


#3

i solved that too by finalising the space before adl_adinstall.

but now i have a worse problem. i successfully downloaded the file, finalised and installed but when modem restarts now it doesnt start new application. No application running on it. And also it displays some messages like
+WIND: 13
+WIND: 4


+WIND: 7

and restarts again. i can not stop it because terminal program doesnt let me write any command. i tried so many thing but couldnt stop it. i dont know what happen. only thing i know is that modem restarts in a loop and i can not stop it


#4

i stopped modem with dwlwin 4.0.0.0 software . i had to install OS OPEN AT libraries also edlib ad-ons. anyway i saved modem but when i run the code it again couldnt download it . now i will try downloading .dwl file before .wpb.dwl file. i saw this info at viewtopic.php?f=4&t=994&p=3436&hilit=ADL_INIT_DOWNLOAD_ERROR#p3436 i hope it will work.


#5

no it didnt work. it made worse. now modem’s led is off and doesnt work. it stops and never starts. i dont know why i m facing these problems. Isnt there any way to process DOTA in open at 3.10? ( save this thread to be my daily , pls post some ideas )