BX3105 fails to connect to Holux M-1200E BT GPS device


#1

I have tried connecting to a Holux M-1200E BT GPS device but recieve the following:

ets Jun 8 2016 00:22:57

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0x00
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:2
load:0x3fff80b8,len:8
load:0x3fff80c0,len:460
ho 0 tail 12 room 4
load:0x40078000,len:16040
ho 0 tail 12 room 4
load:0x40080000,len:296
entry 0x40080060

READY

+SRBTINQ: “00:1b:c1:07:d9:7e”,001f00,-71
+SRBTINQ: “00:1b:c1:07:d9:7e”,001f00,-71
OK

+SRBTSTATE: 1,2,1
OK

+SRBTCFG: 1,0,“00:1b:c1:07:d9:7e”,SPP,0
OK

+SRBTPAIR: “00:1b:c1:07:d9:7e”,0,34

Looking this up the is a failure to pair with HCI code I assume 0x34 “Reserved Slot Violation”.

I am able to connect to a Garmin GLO using this same command sequency just fine. I am able to connect to this same Holux M-1200E just fine from other BT devices. So it seems there is some incompatability between the BX3105 and the Holux M-1200E? The Holux is an old BT Classic 1.2 device, perhaps this is a hint as to the issue?

Any suggestions for how to connect to the Holux greatly appreciated. I am new to the BX3105 and may well be doing daft things …


#2

Hi,

What firmware are you running on the unit (at+fmr)? P1 firmware is due but in the next week or so on the FOTA server, this might fix it.

In theory the BT 1.2 should not affect the unit connecting because it should all be backward compatible.

Regards

Matt


#3

Thanks Matt:

R1.3.0.201816011422.BX310x_1


#4

Will,

That’s reasonably recent for what we have released (the latest is 1.3.1). You will need to test the P1 firmware when it comes out in the next week or so, if it still fails then I think you will need to push back into your commercial channel for some support.

Regards

Matt


#5

Sounds like a plan, thanks!


#6

It has been a while, but I am trying again, this time using:

AT+FMR
P1.0.0.201805311132.BX310x.1

OK

The production firmware. Same result:

+SRBTPAIR: “00:1b:c1:07:d9:7e”,0,34

I did try the latest RC to:

AT+FMR
R2.4.0.201810031030.BX310x.1

OK

But I got even less far with that:

AT+SRBTINQ=10,1
ERROR

It seems I can’t run BT inquiry from the latest RC anymore?


#7

@willmoore,

There is an additional parameter to tell the unit what format to present in.

at+srbtinq=2,1,0
+SRBTINQ: “ec:10:7b:fc:b5:72”,5a020c,-50,“Galaxy S8”
+SRBTINQ: “ec:10:7b:fc:b5:72”,5a020c,-59,“Galaxy S8”
+SRBTINQ: “ec:10:7b:fc:b5:72”,5a020c,-53,“Galaxy S8”
+SRBTINQ: “ec:10:7b:fc:b5:72”,5a020c,-50,“Galaxy S8”
+SRBTINQ: “ec:10:7b:fc:b5:72”,5a020c,-50,“Galaxy S8”
+SRBTINQ: “ec:10:7b:fc:b5:72”,5a020c,-58,“Galaxy S8”
OK

Regards

Matt


#8

Hmm I can see things are on the move with the BX3105 firmware, R2.4 I can’t AT+SRBTPAIR=BT address anymore, but when I AT+SRSPPCFG=BT address, then AT+SRSPPCNX=SPP ID it seems to pair automagically, this works for the Garmin GLO but for the HOLUX I get a:

+SRBTCPIN: “00:1b:c1:07:d9:7e”

So presumably a pin is required, clearly the latest AT commands reference manual does not cover this newer firmware with enhanced BT functionality, so I await the new release then will try again!


#9

@willmoore,

If you try the below command

AT+SRBTCPIN=“00:1b:c1:07:d9:7e”,1,xxxx //Replacing the xxx with the PIN it might work.

Not sure of the above will work in the final release of firmware.

Regards

Matt


#10

@willmoore,

Actually use this one

AT+SRBTCPINCFG=1,1234

Regards

Matt


#11

OK, this is good progress:

at+srbtcpincfg=1,0000
OK
at+srsppcnx=1
+SRBTPAIR: “00:1b:c1:07:d9:7e”,1

+SRSPPCNX: 1,1,130
OK
+SRSPP_DATA: 1,30,$GPGGA,112558.114,0,0,M,
+SRSPP_DATA: 1,95,M,46\0d\0a$GPRMC,112558.114,V,0.00,0.00,141118,N4F\0d\0a$GPVTG,0.00,T,M,0.00,N,0.00,K,N*32\0d\0a

So I can connect to a Holux M-1200E on R2.4, but only if I already know it’s BT address, as it no longer appears in inquiries! Whether I do AT+SRBTINQ=10,1,0 or 10,1,1 it no longer shows … something changed from P1.0 to R2.4 that has stopped the Holux appearing in inquiries it seems? Since inquiries are a subject of another thread, I think I can say I am happy the original purpose of this thread has been served. I can now connect to a Holux M-1200E with R2.4 firmware. I await the full release and the updated AT commands reference to try this “properly”. Thanks for all your help!


#12

@willmoore,

Need to check whether that is the actual cause i.e. if a unit does not transmit a ‘friendly’ name does it get excluded from the displayed list. None of the devices I have are able to do that, phones do not allow you to delete the entire name and the BC127 replaces the name with ‘Bluecreation Melody’ if you delete it.

Push it back to your disti (who I happen to know is SSS) they will raise a ticket and we will put it to the dev team.

Regards

Matt


#13

Thanks Matt, will do!