Building on ubuntu jammy

first, python-jinja2 package now called python3-jinja2. I can install that manually and then set env var LEAF_IGNORE_UNKNOWN_APT=1 to get past that.

but then…

Poky (Yocto Project Reference Distro) SDK installer version 2.5.3

You are about to install the SDK to “/home/wroberts/.leaf/wp77-toolchain_SWI9X06Y_02.36.07.00-linux64”. Proceed[Y/n]? Y
Extracting SDK…done
Setting it up…done
HOSTCC scripts/basic/fixdep
HOSTCC scripts/basic/bin2c
HOSTCC scripts/dtc/dtc.o
HOSTCC scripts/dtc/flattree.o
HOSTCC scripts/dtc/fstree.o
HOSTCC scripts/dtc/data.o
HOSTCC scripts/dtc/livetree.o
HOSTCC scripts/dtc/treesource.o
HOSTCC scripts/dtc/srcpos.o
HOSTCC scripts/dtc/checks.o
HOSTCC scripts/dtc/util.o
SHIPPED scripts/dtc/dtc-lexer.lex.c
SHIPPED scripts/dtc/
HOSTCC scripts/dtc/dtc-lexer.lex.o
SHIPPED scripts/dtc/
HOSTCC scripts/dtc/
HOSTLD scripts/dtc/dtc
/usr/bin/ld: scripts/dtc/ multiple definition of `yylloc’; scripts/dtc/dtc-lexer.lex.o:(.bss+0x0): first defined here
collect2: error: ld returned 1 exit status
make[2]: *** [scripts/ scripts/dtc/dtc] Error 1
make[1]: *** [scripts/ scripts/dtc] Error 2
make: *** [Makefile:559: scripts] Error 2
“Failed to install driver build environment.”
Command ‘/home/wroberts/.leaf/wp77-toolchain_SWI9X06Y_02.36.07.00-linux64/ -y -d /home/wroberts/.leaf/wp77-toolchain_SWI9X06Y_02.36.07.00-linux64/’ exited with 1
Error during installation: Error during install step for wp77-toolchain_SWI9X06Y_02.36.07.00-linux64 (command returned 1)
Remove folder: /home/wroberts/.leaf/wp77-toolchain_SWI9X06Y_02.36.07.00-linux64
Profile provisioning interrupted
Error during install step for wp77-toolchain_SWI9X06Y_02.36.07.00-linux64 (command returned 1)
try leaf profile sync to resume

You can see here

if we were to apply that patch, we would also need to repackage it into wp77-toolchain_SWI9X06Y_02.36.07.00-linux64.leaf, so the leaf tool would use it on the next build-install.

will you consider to downgrade GCC version?
Will you consider to install Ubuntu 18 in VMWare?

i have installed ubuntu 18.04 in a virtual box. It has gcc-7, and ubuntu-22 has gcc-11.
I ran thru the installation on the ubuntu-18 VM, but after i setup the target and profile, and go into leaf shell. The mkapp (and mksys) give error

Bad configuration environment file path

pointing to a in my workspace leaf-data that doesnt exist. Perhaps i missed some step?

Did you do it in vscode?
Have you tried to download another package in vscode and see if there is problem?

yes i tried that.
But i got stuck at the step for 7 create a new system. There was an error in the terminal saying mkedit couldnt find the .sdef file.

you mean this after “Cntl +Shift + p”?

no, I did the ctrl-shift-p and Developer: Reload Window, then it asks for open sdef file or create.
I did create.

“Cntl +Shift + p” should show “Legoto/System New”

how is your profile now?


i created a new VM with ubuntu-18 and installed vscode & leaf on it.
It got past the system create, did that ok.
But then, after i create an app and try to build it, it complains that it cant find header file “le_fwupdate_inerface.h” at #include “interface.h”.
I’m using in the profile swi-fx30-cat1_2.0.0 and swi-vscode-support_200624

And if i go back to another terminal, and leaf shell, mkapp reports “Bad configuration environment file path”

is it the same for other package?

i create two profiles for each of those, but the same system and app is there. Do i need to refresh the includes paths somehow?

I don’t know…
how do you refresh the include path?

Seems same issue as this one:

I wonder if rebuild the legato by “make clean” and then “make wp77xx” in “/home/mangoh/Desktop/myWorkspace/leaf-data/p1_red77/wp77-legato/” will help

after some trying, I found that reloading the legato hierarchy view fixed the include problem.

How do you reload it?