BC127 Music Manager Issue


#1

I’m using CSR UFE to generate DSP keys. All seems OK but on the BC127 the MM configure to turn on the blocks doesn’t work.

Specifically I can enable the MM on and off, but if I SET MM with blocks on, GET MM reports that all blocks are off. Only the main enable on or off responds to my set command.

Any Ideas what I’m doing wrong? :smiley:


BC127 Excessive current consumption - has hardware changed?
#2

Hi,

Can you post the commands you are using?

Regards

Matt


#3

Sure, thanks Matt.

I’m sending DSP keys to #24 & 25, setting up the compander, which are acknowledged.

Then I go to SET MM=ON OFF 0 OFF ON OFF OFF. Nothing changes in the audio, if I then GET MM, I get MM=ON OFF 0 OFF OFF OFF OFF i.e, the MM is enabled, but the compander block has been turned off.

I’m using the UFE from ADK 4.0 to create the psr file and then extract the keys from this. I’ve enabled the compander for all codecs in the decoder module - is this correct?


#4

On point I would make about your set command is that the compander block is controlled with the 6th parameter and not the 5th (3D enhancement) as you are setting to on.

Regards

Matt


#5

One other ion, why are you doing this? It seems very complex unless you have a specific requirement?

The below thread might be of interest.

http://www.blue-creation.com/forum/thread-3402.html

As it says really only to be done if you are engaged with CSR/QC directly at which point they should be able to help you.

Regards

Matt


#6

Hi Matt,

Thanks for your help.

You’re quite right, the SET MM commands I wrote in the post were incorrect, however I was using the correct ones on the DUT and I still get the problem I mentioned.

I do have a CSR account, and I can speak to them, and I do have a specific application, but the interface into the CSR 8670 is via Melody, so I just wanted to check that I was addressing it correctly/ it was working correctly.

The CSR tools allow me to generate the DSP keys, and the Melody MM_CFG lets me apply them, but the Melody SET MM command is native to Melody, rather than CSR, so I just wanted to make sure I was using this correctly. I’m assuming that you’re adding a layer of control onto the DSP Keys, so any help here would be greatly appreciated.

So my issue is that I SET MM, but when I GET MM the results are different. Do you know if I have done something wrong, or is it a bug?

Cheers!


#7

The procedure looks good to me and I get similar results when I try to turn the blocks on i.e. I set them and then read back to find that they are off.

To get a hard answer we need 2nd/3rd line support, for this you need to raise it through your commercial channel so they can get this ball rolling.

Regards

Matt


#8

Thanks Matt,

Will do.


#9

Hi @crookwood @mlw

I got same issue while trying to enable user EQ block on Melody 6.1.5.
SET MM=ON ON 0 OFF OFF OFF OFF
GET MM : MM=ON OFF 0 OFF OFF OFF OFF

Hope you can help me to resolve that.

Best regards,
Eric