BC127 BLE Advertising lasts only 4s

I want to use the BC127 as a BLE peripheral and therefore want it to advertise.

But for some reason the module sends advertising packets for only about 4s, then I can not receive anything from the module anymore. The module starts sending advertising packets after about 45s (again for only 4s).
At least that is what the nRF Connect for Mobile App is showing.

I started my tests with the default BLE_CONN_PARAMS. I can’t see any parameters that would change this behaviour.

What is causing this behaviour? Is it just a wrong parameter and I simply misinterpret the BLE connection parameters? Or is it some other module specific thing? I want the module to advertise constantly until I receive a connection request.

Hi @j.sandrock,

I have just tried BLE advertising case on my BC127 module with the latest offical FW Melody_7_3, I see it works normally. You can refer to these logs:
BC127_advertising.txt (373 Bytes)
BC127_scan.txt (71.8 KB)

With advertising module having name BC01908C (module A) and scanning module (module B), I have checked with 2 cases:
1, When turn-off advertising BLE on module A → module B cannot find module A.
2, When turn on advertising BLE on module A → module B can find module A with 17 times in 60 seconds and 32 times in 120 seconds. I observe the log, module A is scanned regularly and your issue does not happens on my module.

Can you check the FW of your module? And please can check all parameters related to BLE configuration (BLE_CONFIG, BLE_CONN_PARAMS)


Thanks for your reply, now I’m back from a long weekend =)

I already updated the firmware to Melody 7.3.
128 12 24 24 0 800 100 32 32 64 400 400

Paramters 8 and 9 (adv_interval_min/max) have value 32 because I changed them from default 400 to the minimum value, but it does not make a difference, the behaviour is the same for both settings. I guess that was to be expected, but I still wanted to test it :wink:

But, if it works for you it is not a general behaviour of the module but something with my setup…