AT+CMGS gives "+CME ERROR: 515" when OpenAT runnin


#1

Hi,
If my OpenAt application is running and I try to send an SMS message using AT+CMGS I always get “+CME ERROR: 515”. If I stop the OpenAT application (AT+WOPEN=0) then the AT+CMGS works and the message is sent.
I thought this was because my application was calling adl_smsSubscribe(), but after changing it so that it only calls adl_smsSubscribe() when needed I still get the same result (when my application wants to send an SMS message it calls adl_smsSubscribe(), sends the message and then calls adl_smsUnsubscribe()). I’m using OpenAT 3.01.
I’ve just noticed that AT+CGMR doesn’t work while my application is running either.
I know what the “+CME ERROR: 515” is supposed to mean, but it doesn’t make sense, because my application has no problem sending an SMS message and neither does AT+CMGS if I stop the application.
Any ideas?

regards,
Charles


#2

Does anybody has an answer to this?

I get an CME error 515 whenever I use at+cmgs while I have an open-at application running (any application even a dummy one that doesn’t do anything). If I stop the appl. (at+wopen=0) at+cmgs works normal.

I have 650a with SDK 3.01. Should I move to 3.02 or 3.03 ???


#3

Having done more tests I can say more of what is exactly happening:

So with 650a core soft. version and OPEN AT 3.01

while there is an embedded open-at application running in the modem (I tried 2-3 samples) when you try to send an sms from external application (uart) with at+cmgs you get this:

at+cmgs=xxxxxxxx (enter)

you get the prompt (>) to write the sms.

case a) >hello [works fine]
case b) >hello (enter) {which is ascii 10 and ascii 13}
CME Error 515
error

This must be a Wavecom bug. Confusing the intermediate mode (>) with the OPEN-AT application when you press enter (CrLf character).

Can somebody please inform me if it is fixed in OPEN-AT 3.02 , 3.03 or later??? I wouldn’t like to set a new environment to find out if it is behaving the same way.

Thank you

BR
Costas


#4

Hi Costas,

I don’t know if this is a bug, or a feature… But in any case you should not consider switching to version 3.02. I found some bugs and I think other people here agree that this version should not be used…

Best Regards,
Jan


#5

I should have posted a follow-up to this…
The error seems to be fixed in Open AT v3.10 and I do not get the error since I upgraded to 3.10.

  • Charles

#6

Would you trust v3.03?


#7

Trust? No… but trust more than 3.02 or 3.10…

Best Regards,
Jan


#8

Maybe I have to try 3.10 in a different partition :question: and see how it behaves …

It would not be very nice if it solves this issue but introduces new ones !

Charles what is your opinion is it stable enough (3.10)?

Thank you


#9

That’s software for you! 8)


#10

v3.10 seems to be fine.
I haven’t done much with it, other than fix a few bugs, but I have had no complaints from the customer using it for 2 months or more…

  • Charles