AirVantage AT commands not implement? on fx30 microcom

Hi so I managed to communicate with airvantage before somehow but its not working now so I tried to go back in and redo it but none of the at commands work and microcom -E also has -E as unknown?

microcom /dev/ttyAT

gives AT an “OK” but when I type in

AT+WDSI?
+WDSI: NOT IMPLEMENTED
It’s not implemented not sure how to debug this can anyone help? I havent touched the firmware

Manufacturer: Sierra Wireless, Incorporated
Model: FX30(WP7702)
Revision: SWI9X06Y_02.16.06.00 7605a6 jenkins 2018/06/20 17:56:12

Hi there,
Which firmware version are you running?
I suspect you have an early sample. If it’s not R9.1.1.013, please install this version which is available on the Source.
BR,
Chris

image
Im pretty sure this is release 9.1? and also it was working before but then suddenly stopped. I have version 18.9.0 of legato will this be a problem? The base legato version is 18.6.1 but this shouldn’t have any affect on the microcom should it? For some reason it knew the AT commands before but now it doesn’t I’m pretty sure it still worked even after I ran legato update as well? dunno exactly maybe I’ll try setting new firmware up anyways

Hi I did try with FX30_WP77xx_full_R9.1.1.013-generic.cwe and also release 9.1 firmware could this be an issue with my legato version? gonna try re install 18.9.0

Yea microcom -E (micrcom /dev/ttyAT still works) and at+WDSC both still do not work. Really strange I might try downgrading to the legato base version. Also tried putty on windows and still getting not implemented

EDIT: Also I’m using an LTE-M Ethernet version

Hi sast5,

To clarify, I think what you’re saying is that microcom and the WDSx commands are fully functional with R9.1.1.013 and base Legato 18.06.1. However, when you update to Legato 18.09.0, the WDSx no longer function. Is my understanding correct?

I suspect there is a change in the data structures in the newer Legato version. Could you please try the following:

rm -rf /data/le_fs
reboot

And then try the WDSx commands again?

BR,
Chris

Hi that didn’t seem to help. I deleted le_fs then rebooted (the le_fs file came back I’m assuming that was supposed to happen). I haven’t downgraded back to 18.06.1 yet because I’m on a corporate network so it will take me a while to set up a new tool chain etc I was going to try and reset it to factory but I can’t use the at command to enable factory recovery -_- so I’m going to try downgrading back when I get time.

All the air vantage commands give not implemented. Most of the standard at commands work but factory recovery gives ERROR so I don’t know I assumed the OS was just formatting the commands in a way the firmware couldn’t understand.

Hi sast5,

Could you tell me where you downloaded your Legato code from? Afaik, there are 4 potential locations:

  1. FX30 source page
  2. Legato.io release
  3. WP7702 source page
  4. github

If you downloaded from github, there are 2 Legato applications missing: atAirVantage / atQmiLinker

I’m not entirely sure why these aren’t included, but I am investigating internally. Could you please try building from the legato.io source code?

BR,
Chris

Pretty sure I downloaded it from the Legato.io release page