Adb devices - Win 7 x64 no devices attached - any ideas?


#1

Hi

We are not seeing any devices reported when running adb devices
Running on Windows 7 x64

We see:

We found adb.exe in C:\adt-bundle-windows-x86_64-20140321\sdk\platform-tools - which is different from the instructions

With a WP7104 attached - in device manager we can see Android Device \Android ADB Interface

C:\Users\Owner.android\adb_usb.ini
looks like this

Any idea how we debug where I’ve gone wrong ?

Thanks in advance

John


#2

Hi John,

Did you also modify the android_winusb.inf mentioned in the documentation?
legato.io/legato-af/14_1/get … _host.html

Thank you,
Enoch


#3

Hi Enoch

Thanks for getting back to me - I am fairly sure we have “android_winusb.inf” set correctly to be sure I have added both android_winusb.inf and adb_usb.ini here:

dropbox.com/sh/kyhgypa2ho3q … lpdJzxiZ7a

When I plug the dev kit in we see in device manager:

I have also tested that ADB works on my machine with an Sony D5503 running android 4.4.2 - the Sony works no problem:

Do I need to run something else on the target to make adb work?

I tested the WP7104 setting:

Any ideas gratefully received - I really need to get this platform upgraded to the latest legato release

John


#4

Hi John,

If you are upgrading to the latest you don’t need to have ADB working. There is an update package for the WP7104 at developer.sierrawireless.com/Res … ution.aspx (as long as you are signed in). That allows you to upgrade both the module firmware and linux to the latest factory version.

To upgrade (if you have the SW drivers installed) set your boot switch to LOW/OFF on the dev kit, connect to your PC and run the installer program.

Andrew


#5

Ok I seem to have fixed the problem by carrying out the procedure here:
[url]https://forum.sierrawireless.com/t/alpha-b-upgrading-to-14-04-results-in-a-brick/11930/9]

I’ve no idea why - and after a long wait - now I see in device manager

I hope this helps someone else as I messed with this for 6 hours before finding the fix

Cheers

John


#6

Hi Andrew

Thanks - I’ll try the other method now :laughing:

Got the downloads.sierrawireless.com/leg … to-cwe.exe install to work no problem

To save time would you mind pointing me at instructions to install:
downloads.sierrawireless.com/leg … 04.tar.bz2

Cheers
John


#7

Hi John,

Do you have a Linux host available? Or are you trying to do this completely from Windows?

In general, once you have the firmware flashed and can access the console you need to follow the instructions at:

legato.io/legato-af/14_04/ge … octoImages

This assumes that are you have fastboot working from your host. Let me know if you are still having trouble.

Regards,
Andrew


#8

Hi Andrew

The instructions to “Flash Yocto Image” worked great thanks

I used the prebuilt image at http://downloads.sierrawireless.com/legato/Legato-Dist-PreBuilt-mdm9x15-14.04.tar.bz2 and fastboot on a windoze machine

Everything seems fine - except that on the WP7 target I now have :

  1. the socket up board Ethernet port seems to be off
  2. the usb IP port seems to be off (at the target ifconfig only shows loopback)

Andrew Newton resolved 2. after many hours reading through the target (WP7) scripts and came up with the following workaround:

in /etc/legato
create a file called usbmode // I had this wrong and have edited this post
In file usbsetup add text
"ecm
acm
"

Any ideas regarding how to fix 1. ? maybe something similar to 2.
Is there a correct way to implement 2.

A side effect of adding this file is that now the windows drivers don’t work :frowning:

Kind regards

John


#9

Hi John,

you need an AT port for this. I presume you either have one through a Windows or Linux host - if not we can help you get that set up. Try the following:

AT!UNLOCK=“A710”
AT!CUSTOM=“HSICENABLE”,1

Your seeing the effects of having an earlier device which had a firmware bug which has been undone. This setting should turn your Ethernet back on.

Regards,
Andrew

p.s. just reread your previous post. Your solution for USB is fine for now. In order to enable an AT port as well add another line in the same file which says “acm” and reboot. You should then see another tty on your host (I think it’s ttyACM0). If you connect to this (115200, 8bits, no parity) you will have an AT port.


#10

Hi Andrew

That’s great many thanks for the quick response

I would never have guessed that a radio type AT command setting controls the Ethernet interface :smiley:

Cheers

John


#11

If you’re at Dev Days in a couple of weeks ask me about it and I’ll explain why.

Regards,
Andrew


#12

HI Andrew

Ok great thanks - I’ll be over Thurs and Friday

Probably asking lots of odd questions :slight_smile:

Cheers

John


#14