Access Internet


#1

Hi
In my current configuration I have WP7502 over MangohRed board and a 4G sim. It is connected to my PC via CF3 USB. I have QMI drivers and Sdk configured on Ubuntu. Upon connecting I get qcqmi0 and 4 ttyUSB[n] for this board. The system gets a dynamic ip of 192.168.2.3 and I can login as a root to the board via 192.168.2.2. I use legato command: “cm data connect” in WP shell to turn on the data connection. Internet Ping via WP works fine.
My question is, how to access the WP’s internet from the PC?


#2

Hi,

The two IP connections are completely separate and you cannot 'bridge them with any command, you need to do one of two things to make this happen.

  • Write a Legato application to do what you want. The one in the post below will give you a starting point.
  • Use the unit as a dumb modem and connect it as per the attached (it says MC73 but is applicable to most of the current Q based units).

https://forum.sierrawireless.com/viewtopic.php?f=182&t=11033&p=43387&hilit=3G+router#p43387

Regards

Matt
SWI Technical Note - Migration from DirectIP to RMNet on MC73xx Rev002.docx (347 KB)


#3

Thanks mlw!
I tried the 2nd solution - basically use WP7502 as a dumb modem by following the doc. Currently via AT commands I can connect to internet. Upon issuing AT+cgpaddr=1, I get internet ip.
But on my ubuntu, eth0 is not getting any ip - which is the new interface created by WP7502.
Any clues?


#4

Try

sudo dhclient eth0

Regards

Matt


#5

Thanks mlw. It worked. :smiley:


#6

Hi,
Now I’m using WP7502 in dumb mode by linux pppd demon and ppp interface
Say please, how can I enable eth0-eth2(at least one) for WP7502 for internet using.
Now eth0-eth2 not working and not up by ‘dhclient ethX’ commands.
Advise me, please, the sequence of AT-commands to enable connection by eth0-eth2(at least one)? Or appnote for this procedure for my WP7502.
Thank you