7455 AT Commands -- "OK" goes away

This is hard to search for…

I have a Lede-OpenWRT/Sierra MC7455 router, things hum along for 24 hours or so, then I lose network.

When I minicom into the AT Command port and run commands, I don’t get the OK/ERROR echos any more, I get numbers. Like:

which responds with a carriage return (no line feed) that overwrites the AT, like

(The number 0). If there’s an error, I get codes, like “4”.

If I do an AT!RESET, everything comes back fine, I get my OKs and ERRORs and I’m good for another 24 hours or so.

I do send/receive AT commands pretty regularly, like AT!GSTATUS?, and maybe something is getting garbled and I send the wrong AT command to put it in this state? Is there an AT command to get this kind of state, and another to bring it back without doing a reset?


Hi Peter,
This may because AT command “ATV” setting… Probably some app/script set it to “0” so “OK” gone.
Would you try send “ATV1” when “OK” does not come?


Thank you! ATV1 does bring it back. It’s possible I sent a garbled ATV at some point in my script. I’ll look for that, but ATV1 does bring back the OK/ERROR texts

Thanks testing, Peter.
If that works, please help mark solution for this thread to close.