W32K under OPENAT


#1

we are trying to make Q2686 enter sleep Mode by using OPENAT application, There also got error and Q2686 could not enter sleep mode, anybody can help me?

bool SleepResponse(adl_atResponse_t *response)
{
char string[120];

adl_atSendResponse ( ADL_AT_RSP,response->StrData);

}
void EnterSleep()
{
int returnValue = adl_atCmdCreate(“AT+W32K=1,0\r\n”, ADL_AT_PORT_TYPE (ADL_PORT_UART1, FALSE),
SleepResponse, “*”, NULL);
}


#2

Hi,

What is the error received.

Does the application goes in SleepResponse handler.

Thanks.


#3

Yes, the application goes in SleepResponse handler, but only got “ERROR” message.


#4

This works for me:

adl_atCmdSend("AT+W32K=1,0", NULL, NULL );

#5

But then you don’t know if the AT command succeeded or gave an error.

OP should do AT+CMEE=1 to get a proper error code together with the error.


#6

Have you tried the command without the program running to see if you get an error?
The \r\n in the string is not necessary btw.


#7

It worked after removing “\r\n”, thanks a lot for the help


#8

That’s interesting :open_mouth:

I knew that the \r\n was not necessary - but didn’t realise that it actually made a difference!

Is this an expected behaviour, or a bug :question: