Using Fasttrack as Modem / problems with installing driver


#1

Hello all,

I wanted to run Fasttrack as a modem for a Mobile Device (Windows CE 6.0 / Processor: ARM920T-PXA3xx). There are even drivers for respective devices (Windows CE 6.0 , Processor ARM920) but if I execute the CAB file on my mobile device it gives me a error message:

“The application cannot run on this device type. Please install the application specific of this device type.”

Maybe there are some problems with certificates? But I have problems to connect the device directly to my PC, so it I don´t no how to change security options on the device itself.

I would be glad if you could help me / give me a hint.

Thank you very much!
Alberto


#2

Solution: My college asked the wavecom support dirctly and got a Generic driver for ARM processors. With this it works…


#3

New Problem:

After installing the Windows CE Generic ARM driver for Fasttrack on my mobile device I tried to connect the Fasttrack via Mini-USB to the mobile device in order to use it as a Modem… if I want to set up the connection I get following error:

“The modem is not plugged in or is out of service. Connect a modem to your computer and try again.”

Do I have to change any setting (baudrate or TCP setting? before I´ve used the device via Serial Port and it worked very well!)

Thanks a lot!!
Alberto


#4

Is the modem’s USB port enabled?

viewtopic.php?f=7&t=3766&hilit=enable+usb#p15519


#5

Hiya,

The Fastrack is a USB SLAVE device.

Is your Windows CE device USB port a Master device? Mini USB is usually only for B type slave connections - so you usually can’t connect two Mini-B device/connectors together and get a valid link. Only exception (that I know of) is for USB ‘On The Go’ - which requires special master and slave devices. The Fastrack doesn’t support USB ‘On The Go’.

ciao, Dave