Update firmware for EM7565 in Android device


#1

Please help me specific instructions to update firmware for this module. I used SierraFwDl7xxx but I didn’t succeed. Please help me. Thanks so much.


#2

Which Android RIL and EM7565 FW you are using?
Are you storing the FW binary properly?
It helps to understand the issue if you can share more logs and SierraFwDl7xxx command you used.


#3

Currently, Android RIL is version 8.1.2.0, EM7565 FW is version 01.00.02.00.
I stored it in folder /data/em7565/ both .nvu and .cwe
I’ve command followed by it’s examples:
To display info about image running on module:
_ SierraFwDl7xxx -m 9x07 -l_
_ To display info about images on module and host:_
_ SierraFwDl7xxx -m 9x30 -l -p /data/Img :_
_ To download/switch an image for 9x30:_
_ SierraFwDl7xxx -m 9x30 -d -p /data/Img -s 2_
_ To download image for 9x07/9x15:_
_ SierraFwDl7xxx -m 9x15 -d -p /data/MC73_
When I command SierraFwDl7xxx -m 9x50 -l, the device is show “SWI_API_QMRR1_SOCKET_0” and nothing else although the device is still receiving.
Please help me fix it, I am using Android 8.1. Thanks so much.


#4

Thanks tqchuong95.

Sorry I don’t have EM7565 nor Android 8 device, may I ask is RIL working with EM7565 during your test?

If yes, would you please run as root and try stop RIL daemon then run SierraFwDl7xxx again to see any different? i.e.

su
stop ril-daemon-qmi
killall slqssdk
SierraFwDl7xxx -l
ls -l /dev/qcqmi* /dev/ttyUSB*

Thx


#5

Thanks lotam.

I tried to it and I was used SierraFwDl7xxx. The reason may be stop RIL daemon. But I cannot update firmware, althought Firmware updated successful. Can you help me fix it? Thank you very much.


#6

Thanks for testing, tqchuong95.

Yes, SierraFwDl7xxx cannot work if RIL daemon is running and occupy the device.

May I ask what is the exact new behavior faced?
SierraFWDl7xxx able to finsh firmware flashing but device stay in old firmware?

Sorry I don’t have EM7565 or Android 8… Please provide full log in your test to understand.

Otherwise hope other forum user can share the experience…
Thx


#7

Thanks lotam,

I’ve used command: SierraFwDl7xxx -m 9x50 -d -p /data/em7565 -s 2 to flash firmware. I was waiting for firmware flash succesful. But I used command SierraFwDl7xxx -m 9x50 -l but the device’s version is not updated. I’ve copied file .nvu and .cwe version 01.00.07.00. Can you help me? Thanks.


#8

Hi tqchuong95,

Again, sorry I don’t have device to test, best you can provide full log to understand the behavior.

SierraFwDl7xxx -m 9x50 -l
ls -l /data/em7565
ls -l /data/em7565/2
SierraFwDl7xxx -m 9x50 -p /data/em7565
SierraFwDl7xxx -m 9x50 -s 2
SierraFwDl7xxx -m 9x50 -l

Or wait for other forum user comments.
Thx


#9

Thanks lotam,

I may have encountered some firmware problems, I have now updated. Thank you very much, I look forward to continue to receive your support again if I have other problems. Thanks so much. :wink:


#10

Hi tqchuong95,

Glad the issue is solved.
Would you please mark this ticket as solved?

Thx!