UART2 settings


#1

Hello,

I am trying to configure the UART2 port on a Q2406B board. With the AT cmmands ICF, IFC and IPR I can congigure and check the settings of UART1. With the OpenAT function adl_atCmdCreate I can use these commands tho configure UART2 (when I use ADL_AT_PORT_TYPE(ADL_AT_UART2, FALSE) as second parameter). But I cannot find a way to check the settings of UART2.

Can anyone help?

Thanks,

Bart


#2

Hi Bart,

so which setting are you interested in to check?

I think you should be able to get the current settings with AT+ICF?, AT+IFC? and AT+IPR?

Best Regards,
Jan


#3

Hello Jan,

I would like to check all three of them. When I use the commands you mentioned I get the state of UART1 only. I want to check UART2.

Hope you have an idea for that.

Kind regards,

Bart


#4

Hi Bart,

when using the ADL_AT_PORT_TYPE(ADL_AT_UART2,…) you should get the values for UART2. Does that not work? Did you save the values with AT&W - also using the ADL_AT_PORT_TYPE macro?

And which version of the core firmware are you using? (You can check this with the ATI3 command…)

Best Regards,
Jan


#5

Hello Jan,

This works fine but in an Embedded Application only. I was wondering if there is a way to check the settings “by hand” by typing AT commands in Hyper Terminal.

Thanks,

Bart.


#6

Hi Bart,

I see… The problem you are facing is that setting or reading the configuration in Hyperterminal only works for the port connected to the Hyperterminal. So if you connect the module’s UART 2 with the PC you will be able to set / read this configuration but not the configuration of UART 1 of the module.

This is the observation I made, and I think this is still true for current OpenAT versions…

Best Regards,
Jan


#7

Jan,

Thanks for your answers.

Regards…


#8

Hi Jan,

is it possible to send AT-Commands over UART2? How must the Q2406 be configured to do this? In my system I see the WIND messages (for example) at UART1 and UART2, but I get no response to any AT command sent over UART2 …

Best regards,
Ralf


#9

Hi Ralf,

Is an application running? If not, I would assume that the UART 2 is in AT mode and it should work to enter at commands and get the responses there! Which version of OpenAT are you using?

Best Regards,
Jan


#10

Hi Jan,

no, there was no application running. I’m using OpenAT v3.10, the answer of ati3 ist 655_09gg.Q2406B 2015268 111705 17:01.

Best regards,
Ralf


#11

Hi Ralf,

hmmm… that’s strange… I was using OpenAT 3.03 and it definitely worked… The port seems to be activated, otherwise it would not see the indications, and baudrate and other port settings seem to be OK, too - otherwise you wouldn’t be able to read the output…

I can’t think of any other settings that need to be set… I think it should work just fine with your setup.

Maybe check the connection of UART 2 RX. Maybe the module doesn’t receive what you are sending?

Best Regards,
Jan


#12

Hi Jan,

maybe my q2406b is configured wrong because I use the UART2 to communicate with an external device while I develop my application normally

Best regards
Ralf