UART raw access example


#1

Newbie here. I’ve run this example and entered AT+WDU=1,“UART1”,115200 to initialise the UART which seems to happen (I’ve added some debug outputs), but typing into the hyperterminal does not create an event. I guess this may be something to do with the port reuse (to send AT commands and to detect the user input - the example changes the use input’s case - upper to lower and vice versa)? As this is a simple example, what am I missing, it must be something obvious? :confused:

PS. I’m using Q26 FastTrack Supreme 20


#2

Well, I’ve added a second PC on COM 2 and tried communicating with that and still get nothing. The characters appear in the TMT Data window but the sample app just sits there waiting for a serial event. This is getting annoying now! It must be some thing simple. :angry:


#3

viewtopic.php?f=53&t=2509&p=11123&hilit=external+com#p11123

Have you opened the 2nd port from the ‘External Com’ menu?


#4

Yes. I can see the External Com data coming in in the TE Data window, but the application is just sitting waiting for the event here:

  TRACE((1, "Wait for a Received Data......"));
  adl_atSendResponse(ADL_AT_RSP, "\r\nWait for a Received Data......\r\n");            
  /* wait for Rx Available event */
  adl_eventWait( EventHandle,
                 RX_EVENT_WAIT_MASK,
                 NULL,
                 ADL_EVENT_WAIT_ALL,
                 ADL_EVENT_NO_TIMEOUT);   
  adl_atSendResponse(ADL_AT_RSP, "\r\nEvent received\r\n");    

The event received output is never seen.


#5

The simple answer to this, is that the example doesn’t work with the FSU and the comm port mux. Even with an extender board giving a second serial port, I couldn’t get it to work.
It does work with the dual port dev boards.

I have since got the ports working OK using the FCM method of controlling the uarts.