Text Mode Parameters are not set


Module: Q2686
openAT Firmware: 6.52

I am trying to change the Text mode parameters using the command AT+CSMP.

The value set to module was +CSMP: 49,167,0,242 .

I tried to change the value using AT+CSMP=1,167,0,0.After wrting to the module its responds with OK.

If i try to read the parameters it shows the previous values 49,167,0,242.

I tried to Restore the module using AT&F for factory reset but the values are not changed. How do i overcome the problem


I am not facing this issue… m able to change the parameters successfully.
can you try with other FW and other module?
also if you have developer studio can you log ATI level 1 trace?

Thank you Rex_alex

I have seen this issue in only one of the module other modules are working fine.
What might be the cause for the problem like ,Is the memory (to which i write parameters)corrupted? If it is the case how to confirm.
The module with which i am facing the issue is in remote location so i cant connect it to dev studio and trace it.