Starting slqssdk with MC7710


#1

Hi all,

I am trying to test the QMI mode on MC7710, but I am always getting “Unable to find device…”
when running Connection Manager sample application.

I am using SLQS03.00.02, binary only version.

I have compiled GobiSerial and GobiNet successfully. I switched MC7710 to QMI mode and
loaded modules and I get:

GobiSerial 1-1.3:1.0: GobiSerial converter detected
usb 1-1.3: GobiSerial converter now attached to ttyUSB0
GobiSerial 1-1.3:1.2: GobiSerial converter detected
usb 1-1.3: GobiSerial converter now attached to ttyUSB1
GobiSerial 1-1.3:1.3: GobiSerial converter detected
usb 1-1.3: GobiSerial converter now attached to ttyUSB2
usb0: register 'GobiNet' at usb-isp1761.0-1.3, QmiNet Ethernet Device, 2a:60:5c:bb:1d:ca
creating qcqmi0

I have checked that all three /dev/ttyUSB[0-2] are working and also created /dev/qcqmi0 with
proper major and minor numbers.

I have copied connectionmgrarm and slqssdk on my target and when I run:

> ./connectionmgrarm SDK/build/bin/arm/slqssdk 

Unable to find device..

I also tried using strace on both binaries, but I cannot find any open system call
to /dev/ttyUSBX or /dev/qcqmix.

Went trough “Linux QMI SDK Application Developer Guide.pdf” but it seems I have
done everything right, well except for building the SDK since I do not have the
source code.

What am I doing wrong?

Thank you and Regards,
Matej


[ help ] [ MC7430 ] USB ioctl open error: Permission denied
#2

root permission?


#3

Hello,

I am running this on an Embedded computer on ARM board
with root permissions.

Regards,
Matej


#4

Hi Matej,

Thx for update.

How about running the it as below?

SDK/build/bin/arm/slqssdk &
./connectionmgrarm SDK/build/bin/arm/slqssdk

Thx


#5

Lotam,

tried as you suggested, but the results are still the same.
As said before, when using ‘strace’ ob both binaries, I didn’t see
any references to /dev/qcqmi0 or /dev/ttyUSB0.

I can send you those logs, if you need them?

Thank you and Regards,
Matej


#6

I know this thread is pretty old, but I am having the exact same experience using an EM7565 module running Ubuntu 18.x.

Was there ever a resolution to this issue?

grace


#7

@gracette,

This is almost always to do with permissions for the /dev/qcqmi interfaces for the currently logged in user. Assuming you have compiled your GobiSerial and GobiNet interfaces into your system and subsequently have the corresponding /dev/ttyUSB and /dev/qcqmi interface(s) send the below command

  • ls -l /dev/qcqmi*
  • sudo chmod 777 /dev/qcqmi

If the first command does not return something like the below then it means you do not have full read write permissions to the interface over which the QMI protocol needs to flow meaning the SDK cannot find the device, hence the response.

crw-------- 1 root root 248, 0 0 Sep 17 16:18 /dev/qcqmi0

Regards

Matt


#8

Hi Matt,

It does indeed appear to be a permission thing. I was able to resolve it by rebuilding and installing the Gobi* driver modules as root. Issuing the build commands using “sudo” was not sufficient possibly due to some pipes in the make commands. I used “sudo bash” to create a root shell and then issued the make; make install commands for both drivers. The /dev/qcqci0 device is still showing crw------- permissions, but many other device nodes have similar perms and it seems to be working.

Now running “sudo conman slqssdk 0” is working as expected. I can initiate an LTE session and server up a test video file.

Thanks for putting me on the right track!

grace