Send SMS and CMS ERROR 305


#1

Dear all
I’m trying to send SMS with a terminal connected to the Fastrack supreme 10 but always get the CMS ERROR 305 “Invalid text mode parameter”.
I tried to change the text mode prameter, but no way.

Here are some traces of the AT commands I send (bold) and responses of the modem
at+cnmi?
+CNMI: 0,1,0,0,0
OK
at+csmp?
+CSMP: 17,169,0,0
OK
at+cmgf=1
OK
at+csca?
+CSCA: “+41794999000”,145
OK
at+cmgw="+41797943078"

hello
+CMGW: 1
OK
at+cmgs=1
+CMS ERROR: 305

at+cmgl=“ALL”
+CMGL: 1,“STO UNSENT”,"+41797943078",
hello
OK

Can anyone help me?
Thanks
jln


#2

you try with:

AT+CMGF=1// choose text mode

AT+CMGS= //without “”


#3

Thanks for the reply
Yes, I tried, but same behaviour!
Something strange, if If use the command +CMGS to send the SMS directly, I get an other error code (+CMS ERROR: 513)

at+cmgf=1
OK
at+cmgw=+41774464444

test
+CMGW: 1
OK
at+cmgs=1
+CMS ERROR: 305
at+cmgl=“ALL”
+CMGL: 1,“STO UNSENT”,"+41774464444",
test
OK
at+cmgs=+41774464444
hello
+CMS ERROR: 513


#4

And what does that one mean?


#5

CMS ERROR 513 means ‘lower layer failure’. I found some explanation about it but, one ot them is the MS loses the radio link. But I can start a grps connection with the modem.
And if I put the SIM card in a modemSiemens MC35i , with the same AT commands it works poperly…
I have no more ideas for the moment

:bulb: :question:


#6

This can be an intermittent problem; eg, if there is interference, or a (brief) drop in the signal level…

Does it succeed if you re-try?

What is the signal strength?
Are you in an area of known poor reception?


#7

I don’t think it is a problem of signal, because I can receive SMS without any problem!