Rescue MC7455 after incorrect PID change?

I accidentally changed the PID on MC7455 modem, which cause problem on reconized modem on ttyUSB, and unable to login to AT command terminal. Is there anyway to change the PID of the modem?


Have you tried through Ubuntu OS ? I’ve same problem on MC7304 where that problem was corrected through Ubuntu OS.


I had tried on Windows OS and unable to connect to the AT command prompt. And so I don’t know how to change the PID of MC 7455 back to original 9071.
I tried on Raspbian, I can find sierra usb via lsusb, but unable to recognized usb input via ls /dev/ttyUSB*.

Any ideals?


I’ve done through “/dev/ttyUSB2” via “minicom” on Ubuntu. Please do try below syntaxes.


If these all shown then you could change that value.


This should be easy to fix on Raspbian provided it has a USB serial driver we can use. Try option first:

modprobe option
echo 1199 90xx > /sys/bus/usb-serial/drivers/option1/new_id 

You’ll have to replace the “1199 90xx” with the modems current PID and VID. If that works, then youl’ll have a number of ttyUSBx devices and just have to try which one is the AT serial function. I assume you know how to go from there since you’ve already changed the PID.

If you got a write error, then your Raspbian didn’t have the option driver. If so, then please show us the output of

ls -l /lib/modules/uname -r/kernel/drivers/usb/serial

so we can see if there is another usable driver.

Thanks for reply, this way does not work on my side, no list found under ls /dev/ttyUSB*

Both way are not working. Any ideas?

I could still find modem via lsusb

Sorry, I see now that the ` character was dropped in my previous post. The point of the “uname -r” part was to run a command to get your current kernel version. Please show us the output of

ls -l /lib/modules/*/kernel/drivers/usb/serial

or substitute the real path on your system instead of the asterisk (*). The point is to try to figure out which USB serial drivers you have available on your Rasbian. I don’t know this distro, but I assume it is similar to an ordinary Debian desktop installation.

It is also worth a shot to look at

ls -l /sys/bus/usb-serial/drivers

in case some of the drivers are built-in.

ls -l /lib/modules/*/kernel/drivers/usb/serial

ls -l /sys/bus/usb-serial/drivers


Huh? This shows almost all usb serial drivers for two kernel versions, including option.ko in both.

modprobe option
echo 1199 1199 > /sys/bus/usb-serial/drivers/option1/new_id

should work.

I honestly don’t know. here is my output.

You need to press enter after
modprobe option

It’s two separate commands. The first should load the option driver. This will make the /sys… file appear, and the second command will succeed. The purpose of that is to tell the driver that 1199 1199 is a device it should handle. This driver is quite flexible and will handle the serial functions of your modem just fine. It will create a /dev/ttyUSBx device for each of them. One of these will be the AT function.

That way works!! Thanks.

Hello, after you entered those last two commands, how did you send the command to change the PID?

how about this?

Thank you for that. I have a USB adapter, but don’t know how to send commands with it. Using windows PC. I have Putty program, but I do not know which protocol to use to send the commands. Can you point me in the right direction?

do you see any serial port in device manager?

Yes. It sees EM7565 as USB composite device.

I only see USB hubs, but nothing listed as “serial ports”.