RC7620 and HTTPS

Clearly I lost the will to live mid sentence above, to finish it.

(the HTTP config command does show the option of creating a secure connection in the current documentation).

Hi Matt,

Thanks for the update.

I’ll keep an eye out for the response from your product manager. If the HTTP config does indeed support a secure connection, then that could work for us. It would be surprising to find that it doesn’t with the push for greater security with IOT.

Thanks,
Liam

@Liam,

Having discussed it with the product manager it appears that the firmware will/does support the loading of keys onto the unit using the normal commands and subsequently using the at+khttpcfg command to set it to run over TLS (making it a HTTPS connection).

The command manual needs updating which hopefully it will be shortly.

Regards

Matt

Hi Matt,

Thanks for the update - one of your colleagues reached out about this via email earlier in the week.

I didn’t actually realise that KHTTPCFG supports HTTPS on the HL7692 as well, so it looks like i’ll be able to try that and update our codebase to use KHTTP instead of KHTTPS anticipating any change over to the RC7620 when they become available.

Thanks for your help.

hi @mlw

i also have the same problem with HTTPs on RC7620 module

currently, is there support from Sierra Wireless to implement HTTPs via AT commands?, and is there way of doing it?

thanks

Hi @nguyenquoctien ,

Sierra Wireless will support full actions of HTTPs via AT command on next release of RC76xx device. Detail you can refer to this topic Upgrading HTTP from HL to RC series

Currently, RC76xx supports the actions of HTTP protocol as below:

  • HTTP GET
  • HTTP CLOSE
  • HTTP DELETE
  • HTTP HEAD (Get HTTP headers)

Detail you can refer to this document. AirPrime - RC76xx - AT Command Reference Guide - Rev8.0.zip.001.z (4 MB) AirPrime - RC76xx - AT Command Reference Guide - Rev8.0.zip.002.z (38.6 KB) .Remove “.z” at the filename then unzip them.

Hope this is helpful for you :slight_smile:

Thanks,

@Donald
thanks for your help

Hi everybody.

Now I am donging on the SR7620 module. I have a problem:
I use the HTTP post method via AT commands (refer sample.txt file in this topic “Upgrading HTTP from HL to RC series”. but I have received an error code (+KHTTP_ERROR: 1,5). I do not why. and I don’t know how to fix it.

I have 2 SR7620 modules. A module is loaded firmware version “Revision: SWI9X07H_00.03.03.00 2bb7a4 jenkins 2020/04/15 07:57:29” another is “Revision: SWI9X07H_00.08.07.00 0ce4c1 jenkins 2021/03/17 02:18:20”
both the modules as the same error code when I use HTTP_post.

everybody tell me how to fix it.
detail, please refer to the file attactment. In herehttp_fail.txt (1.6 KB)

[2021-04-13_13:56:34:323]AT
[2021-04-13_13:56:34:323]OK
[2021-04-13_13:56:37:056]ati
[2021-04-13_13:56:37:058]Manufacturer: Sierra Wireless, Incorporated
[2021-04-13_13:56:37:058]Model: RC7620
[2021-04-13_13:56:37:058]Revision: SWI9X07H_00.03.03.00 2bb7a4 jenkins 2020/04/15 07:57:29
[2021-04-13_13:56:37:058]IMEI: 353634110170700
[2021-04-13_13:56:37:058]IMEI SV: 14
[2021-04-13_13:56:37:058]FSN: 7Q1017851913B0
[2021-04-13_13:56:37:058]+GCAP: +CGSM

[2021-04-13_13:56:37:058]OK
[2021-04-13_13:56:43:124]AT+CPINR

[2021-04-13_13:56:43:124]+CPINR: SIM PIN,3
[2021-04-13_13:56:43:124]+CPINR: SIM PUK,10
[2021-04-13_13:56:43:124]+CPINR: SIM PIN2,3
[2021-04-13_13:56:43:124]+CPINR: SIM PUK2,10
[2021-04-13_13:56:43:124]+CPINR: PH-NET PIN,255
[2021-04-13_13:56:43:124]+CPINR: PH-NETSUB PIN,255
[2021-04-13_13:56:43:124]+CPINR: PH-SP PIN,255
[2021-04-13_13:56:43:124]+CPINR: PH-CORP PIN,255
[2021-04-13_13:56:43:124]+CPINR: PH-FSIM PIN,255

[2021-04-13_13:56:43:124]OK
[2021-04-13_13:56:45:848]AT+CSQ

[2021-04-13_13:56:45:848]+CSQ: 28,99

[2021-04-13_13:56:45:848]OK
[2021-04-13_13:56:52:053]at+kcnxcfg=1,“GPRS”,“m3-world”,“mms”,“mms”

[2021-04-13_13:56:52:060]OK
[2021-04-13_13:56:55:202]at+khttpcfg=1,“httpbin.org”,80

[2021-04-13_13:56:55:261]+KHTTPCFG: 1

[2021-04-13_13:56:55:261]OK

[2021-04-13_13:56:55:267]+KCNX_IND: 1,4,1

[2021-04-13_13:56:55:267]+KCNX_IND: 1,2,1,2,30

[2021-04-13_13:57:25:274]+KCNX_IND: 1,4,2
[2021-04-13_13:57:25:282]+KCNX_IND: 1,2,2,2,30
[2021-04-13_13:57:25:285]+KHTTP_ERROR: 1,5

[2021-04-13_13:57:55:290]+KCNX_IND: 1,4,3
[2021-04-13_13:57:55:300]+KCNX_IND: 1,2,3,2,30

Hi @huydai2004,

Following your log, I see that module is having issue with PDP connection. Your module is trying to connect PDP but it can’t, this is shown in notification +KCNX_IND.
Please make sure your module attached network. You can check EPS registration status by AT command AT+CEREG? (Right value of stat parameter is 1 or 5). You can refer below picture:
image
Beside that, can you check APN setting in command +KCNXCFG is the same as APN setting in command +CGDCONT? Please make sure they have the same APN then try again.
If this issue still exits, please send me the log with all AT command you excuted.

Thanks

Hi @jerdung.
thanks for your support!

I checked registration status and It reponded (+CEREG: 2,1,“46F”,“2”,“1C7970C”,7)Capture

But I still receive an error code (+KHTTP_ERROR: 1,5).

Detail, please refer to the attactment file, In here rc7620_faill_http.txt (2.1 KB) (rc7620_faill_http.txt)

Have a nice day!

Hi @huydai2004,

What the login (“mms”) and password (“mms”) value in your AT command +KCNXCFG is used for?
Have you tried to set as below?

at+kcnxcfg=1,“GPRS”,“m3-world”

Thanks,

hi @jerdung

The carrier I am using is VINAPHONE.
“m3-world” is APN.
“mms” is a username
and “mms” is a password
You can refer to this link “Vinaphone Vietnam APN Configuration Settings - APN Settings Search Engine

I to try again as you ask (at+kcnxcfg=1,“GPRS”,“m3-world”,"","") . But I still received an error code (+KCNX_IND: 1,2,7,2,30).

You can see the detail in the attachment file. rc7620_faill_http.txt (1.5 KB)

Hi @huydai2004,

Can you excute command AT+CGPADDR then send me the result?

Thanks,

Thanks for your support! @jerdung

you can see in 107 line. rc7620_check_status.txt (4.4 KB)

Thanks and best regard!

Hi @huydai2004,

Can you check if your sim has data using for internet access? You can refer to below command and send me the result:

at+cusd=1,"*101#",15
at+cmgf=1
at+cnmi=1,1
at+cmgs="888"
> DATA<ctrl-Z/ESC>
at+cmgr=<index in URC +CMTI>

Beside that, please check your antenna, I see in your log, your network signal is not stable:


With:
+CEREG: 0 means: Not registered; MT is currently not searching for an operator to register to
+CEREG: 2 means: Not registered but MT is currently trying to attach or searching for an operator to
register to

Can you provide the result after sending command AT+CSQ? for me?

Thanks,

good afternoon @jerdung.

My SIM definitely has data for the internet. when I plug SIM into the smartphone I can normally access the internet.

Thanks.

Hi @huydai2004,

Are you mounting your module with Windows PC or Linux PC? If you are using Windows PC, you can disable Cellular created by your module as below:

Then you can try to create HTTP connection and send me the result.

Thanks

Hi @jerdung

My PC is Windows. below is the result when I turn off Cellular.
I have a new problem.
when I send the AT+KHTTPCFG=… command.
It responded +KHTTP_IND: 1,1
But after that: I continually send the at+khttpheader=1 command. I have received “CONNECT”. After a while, I receive an error code “+KHTTP_ERROR: 1,6”

You can check in the attachment file.http_header_fail.txt (1.9 KB)

Thanks!

Hi @jerdung

when I ignore the “at+khttpheader=1” . I can post data over the HTTP_post.

I do not know the meaning of “at+khttpheader”? And Why does the HTTP_POST works well when I ignore the “at+khttpheader=1” command? Please send me any document description of this feature.

Please view in the attactment file.http_post_ok.txt (2.8 KB)

And next step. I will test the HTTPS(get and post) please give me some examples.

Thanks!

Hi @huydai2004,

Following your log, I think error code “+KHTTP_ERROR: 1,6” displays because you missed a pattern used to notify the end of data (or file) during data or file transfer (–EOF–Pattern–).

However, +KHTTPHEADER and +KHTTPPOST commands are not mentioned in the latest AirPrime - RC76xx - AT Command Reference Guide here:
https://source.sierrawireless.com/resources/airprime/software/airprime---rc76xx---at-command-reference-guide/#sthash.HuDIYPiN.dpbs
So I strongly recommend you should not use +KHTTPHEADER and +KHTTPPOST commands until they are mentioned in document. These commands are not developed completely at this moment, so you can face the issues with current latest FW.

Thanks,