Q24PL001 GSM Modem not flashing when sim is inserted

Hello, Im not too great when it comes to programming devices or coding but if you can give me the steps I can make it happen as Im decently tech savvy.

As stated above, I bought this GSM modem off amazon. It doesnt look anything like the photo listed and like those cheap ones on alibaba bit sad where my money went but oh well.

Anyways, when I insert the sim/sims (TMOBILE US) it does not flash at all, just stays a constant bright white. I tried using HyperTerminal commands (dont know much) but for some reference for the helpers here it is.

AT command = OK
at+ccid= ERROR
ati3= 657h00gg.Q24PL001 1977628 081909 14:44

How can I fix this? Im out $600 for a cheap product that doesnt even work, and dont want to deal with returning due to me waiting a month for this thing.

Once again the problem is it doesnt detect the sims at all (people say its supposed to blink when it does but mine does not). Ive tried putting the sim card in every single direction but it refuses to blink.

Also in SMS caster it detects the ports when they are turned on but they show UNKNOWN signal once again showing they are not detected.

Im not sure if this is the right forum but this is all I could find googling all around the place as people dont talk about this much. So sorry if this is the wrong forum as this seems targeted at people working with programming the chips themselves. But worth a shot.

do you sure if TMOBILE is still having 2G network?

Hmm Im not sure, they are 4g. Seller advised me it would work with 4g :stuck_out_tongue: What model gsm should I buy for 4g?

Gsm is 2G, not 4G LTE …