problems registering HL8548 to AirVantage


#1

Hello support,

I followed the instructions on doc.airvantage.net/av/howto/har … g_started/ to register my HL8548 modem to the AirVantage platform.

The device has been added to my systems, but I seem not to be able to successfully register the device through the AT+WDSS command (refer to attachment reg_airvantage.png). I follow the following sequence. My SIM card is from a Belgian operator, has data enabled and activated, I use AT+CGDCONT? to check if I received an IP address.

AT+WDSS=0,"internet.proximus.be"
OK
AT+WDSS?
+WDSS: 0,"internet.proximus.be"
+WDSS: 1,0

OK
AT+WDSI=8191
OK
AT+WDSI?
+WDSI: 8191

OK
AT+WDSS=1,1
OK

+WDSI: 4

+WDSI: 7
AT+CGDCONT?
+CGDCONT: 1,"IP","internet.proximus.be","0.0.0.0",0,0
+CGDCONT: 5,"IP","internet.proximus.be","100.73.211.184",0,0

OK
AT+WDSS=1,0
OK
AT+CGDCONT?
+CGDCONT: 1,"IP","internet.proximus.be","0.0.0.0",0,0
+CGDCONT: 5,"IP","internet.proximus.be","0.0.0.0",0,0

OK

FYI:

at+kgsn=1
+KGSN: 3595150587670511

OK
at+kgsn=3
+KGSN: HD649706230110

OK

Any clues?

regards,

Stephan



#2

Hi Stephan,

you have configured your device but you didn’t open a session with AirVantage.

You have to do the following with the result:

at+wdss=1,1
OK

+WDSS:4
+WDSS:6
+WDSS:8

if you have code 7 instead of 8, an error occurred. 8 means successfull (see HL AT command guide for more information)

Regards,
Robert


#3

Hi Robert,

If you scroll down the code snippet from my original post, you can see I did actually issue the AT+WDSS=1,1 command. I received the error code 7:

AT+WDSS=1,1
OK

+WDSI: 4

+WDSI: 7

So in my opinion, it seems that something goes wrong with the registration. I have mode some other tests (try to create TCP and HTTP connection), and they all succeed, so the SIM card has surely data enabled.

regards,

Stephan


#4

Hi Stephan,

sorry, I didn’t see I could scroll down :frowning:

I checked your configuration on AirVantage, all is fine. The module has never communicated with AirVantage. So the issue should come from the credentials provisioned in the module. Sometimes, I saw trying several times at+wdss=1,1 it can work but I can only tell you to contact your reseller’s support team so far.

Regards,
Robert


#5

OK tnx, I will contact our FAE.


#6

Hi,

Did you find the reason that made the registration failed? When I use hl7692 to connect AirVantage, I have WDSI 7 too.

Regards


#7

Hi, this was for a prototype project only, which was not further developed. So, I can’t help you further.