Problem with AT Command

I am using module RC7620 in my product.
The module we are designed to use with UART.

The big problem is the AT command doesn’t work well: it is often stuck.
We’re trying to debug this problem:

  • We are using MangOH yellow kit, connect UART pin of RC7620 with USB to COM.
  • We are making a phone call from RC7620 to Android phone, accept from Android then wait for the response from RC7620.
  • Use case 1: The kit using the external battery without connecting the USB port. After Android connects the call, RC7620 doesn’t respond anything.
  • Use case 2: After the module doesn’t respond, we are tried to connect USB port with external power (the module still working), the external battery still connects. We are tried to make a phone call again. When Android accepts the call, RC7620 responds normally.

The battery is quite good, the stuck happens with many commands (this call command is an example), and this issue happens with lots of RC7620 we have.

I don’t know does USB can affect the AT command.
We debug this issue for a long time, many methods using but doesn’t work.

The video is attached below:

Please help me resolve this problem.
Thank you very much.

does AT command port stuck if setting AT+KSLEEP=0 but controlling the DTR to make module waking up?

Hi @jyijyi ,
We are tried both AT+KSLEEP=0 with DTR, and AT+KSLEEP=2. Nothing works.


You mean it is still stuck?
Or just the "connect " not returned?

It’s both stuck and not repond URC code after connect

Is it duplicate issue?

you can reference my comment and video to help us fix this issue

Then you don’t need to open duplicate topic

Now I will focus to the root topic.

Yes, let’s go back to the original discussion thread then.

1 Like