Problem starting apps


I have a problem with one of my applications. I don’t know why but when I try to start the application from my host: startapp MyApp or when I try to start the application in the target (directly): app start MyApp I always receive the same error:

root@swi-mdm9x15:~# app start MyApp
Starting app 'MyApp'...
There was an error.  Application 'MyApp' could not be started.

But I can start the application through the Developer Studio (connected by ssh). After that, I can execute always MyApp with the startapp & app start commands

Is it an application or a command problem? Which is the difference executing startapp/app start/Start application (devstudio)?



Your application was probably created through Developer Studio, which added a line to the ADEF file requiring a binding for a potential core file.
This binding can be resolved only if a temporary /tmp/ds/yourapp/core file is created before your app is started. This is managed when DS starts the app, but not if you start it manually.
But with Legato 15.01 this binding became useless since now the core files are written in /tmp/legato_logs directory, so you can safely remove it from the ADEF file.

Note that the operation to add this binding at project creation will be cleaned out in DS 3.4

Hi daav,

I didn’t know the meaning of /tmp/ds//core so, thank you for the explanation.

I’ve tried to remove and now I’m able to run the application remotly so it works.

Thank you for your support,