New project


I have created some projects before and they have been working fine. Today I have tried to create a new one. If a create it in an existing workspace I there are a lot of compilation errors, that really don’t exist (for example: ‘ascii’ not defined). If I create it in a new workspace, when I’m on the step of Open AT OS selection I import it, but it doesn’t appear on the Firmware box :open_mouth: . It’s already imported, if I try to do it again, it only appears if I deselect the “Filter already imported packages” option.
Does any one know how to solve this?
Working with 1.0.2 version with automatic update active.


Have you checked that the header files are actually being included correctly?

ie, that both the #includes are correct in the source file(s), and the tools are actually fnding the correct files…

Note that the “Problems” view seems to do some kind of re-ordering of the error messages, so that they do not appear in a sensible order! :angry:

For example, the compiler would actually report “can’t find header file xyz.h” first, and then give a whole load of consequent errors like “‘ascii’ not defined” - ie, the symptoms follow the cause.
But the “Problems” view seems to mess-up that order, so that symptoms come first - eg, “‘ascii’ not defined” - and the actual cause does not appear until waaaaaaaaaaay down the list! :angry:


For the first case, existing project, I copy and past the same SW code I have used in the existing project after I created a new empty project. I do this because I want to generate two branches of development for two ways of doing the same to evaluate the behaviour of each one.
This means that the code is working and compiles correctly if there is only a project in the same workspace. Maybe the problem cames from using the same name .c / .h files between projects of the same workspace. I don’t find this logical, but I can’t imagine any other explanation. That’s why I tried to create a new workspace. :confused:


I certainly agree that Eclipse does seem to live in a world of its own, and operates in a way totally unlike any other “normal” IDE :exclamation: :confused:

I dare say that there is logic to it - but it (appears to be) an entirely different logic to any other IDE that I’ve used before! :confused:

As a VisualStudio user new to Eclipse, I have been recommended the following (though I haven’t read them yet):

An introduction to Eclipse for Visual Studio users … -eclipse-1

Eclipse for Visual Studio Developers … evs-i.html


I don’t have problems with Eclipse, I like it. There are some things that you must include as plugins (for example colums edition, as you require some time ago :smiley: ). The M2M Studio creates a “room” inside Eclipse, that does not allow you to change the things are out of this “room”. I don’t like this kind of things but can accept them, with only one aditional requirement: all other things work fine… :neutral_face:


See: viewtopic.php?f=78&t=4284