MTU greater than 1500 for MC7430 in QMI mode

Hi Community,

I am working on an issue where MC 7430 is configured in QMI mode and it’s getting an MTU of 1900 from the ISP.

Earlier, we had an issue with the isp sending an MTU < 1500. In the
qmi_wwan driver, MTU and MRU are mapped to the same value and upon receiving a packet greater than the configured MTU from the isp it crashes the MC 7430. So we took the patch of setting the rx_urb_size to 1504. This fix is broken for the above MTU setting.

Furthermore, in most forums and in qmi_wwan driver the assumption of max mtu is 1500 only. I also checked the 3gpp specification for the LTE and its suggestion for max MTU is ambiguous(In some places it states that the modem needs to configure the ISP given MTU).

Can you please help me with the right expectation for MTU.


How do you know “it’s getting an MTU of 1900 from the ISP”?

Hi Jyijyi,

Thanks a lot for the quick reply. I am checking the isp provided info via the qmicli.

qmicli -p -d /dev/cdc-wdm0 --wds-get-current-settings
[/dev/cdc-wdm0] Current settings retrieved:
IP Family: IPv4
IPv4 address:
IPv4 subnet mask:
IPv4 gateway address:
IPv4 primary DNS:
IPv4 secondary DNS:
MTU: 1900
Domains: none


What is the problem now if you keep the MTU value to be 1900?

Since we had applied the MRU path, even if the MTU is changed to MTU 1900, the MRU would be at 1504 and it would result in qmi_watchdog. This leads to the modem being unusable.

Can ISP send an MTU greater than 1500 ?


you says you need to set the MTU and MRU to be same value in order to avoid watchdog crash, right?
What would happen if you set both MTU and MRU to be 1900?
If you still want to fix the MRU to 1504, how about setting the MTU to be the same value as 1504 instead of 1900?

Sry for the delayed response, I think qmi driver in Linux has the problem. The host should not receive a packet > MRU and if it is received it crashes the driver. This issue is fixed in the MBPL R28 driver