MC7430 Signal Strength Network Manager

I am using a MC7430 on Ubuntu 16.04. I am successfully using Network Manager to make a ppp connection. However 30 secs after I make the connection the signal strength shows as 0 bars on the nm-applet and mmcli -m 0 starts returning zero whereas before the connection it would return the correct value.
I think this is the clue in the logs

Dec 22 13:38:05 roamescar-pc ModemManager[16197]: <debug> [1482377885.290585] [mm-iface-modem.c:1165] update_signal_quality(): Modem /org/freedesktop/ModemManager1/Modem/0: signal quality updated (0)
Dec 22 13:38:35 roamescar-pc ModemManager[16197]: <debug> [1482377915.290986] [mm-broadband-modem.c:1991] modem_load_signal_quality(): loading signal quality...
Dec 22 13:38:35 roamescar-pc ModemManager[16197]: <debug> [1482377915.291145] [mm-iface-modem.c:934] access_technologies_check_ready(): Couldn't refresh access technologies: 'No AT port available to run command'
Dec 22 13:38:35 roamescar-pc ModemManager[16197]: <debug> [1482377915.291233] [mm-port-serial-qcdm.c:201] debug_log(): (ttyUSB0): --> 4

When the network manager is connected it locks out /dev/ttyUSB2 so I can’t use AT Commands to get the signal strength.
I would be happy to get the signal strength from mmcli or nmcli. I just need to regularly log the value.

As a different approach I decided I would remove modemmanager and try to use qmi-cli and qmi-network.
However I can’t even get a basic command to work. I have removed the modemmanger.

sudo qmicli -d /dev/cdc-wdm1 --dms-get-manufacturer

error: couldn't create client for the 'dms' service: CID allocation failed in the CTL client: Transaction timed out

So if anyone can help me with the first or the second approach?

I think you stand better chances getting a semi-educated answer if you direct your questions to the appropriate mailing list(s) and include a few more details about what you are doing.

If I were to guess based on what you have posted so far, I would say that the modem is in MBIM mode and you lack MBIM support in your ModemManager. But that’s a pretty wild guess since you haven’t really shown us much at all. In any case:Nothing we have seen indicates any issues related to Sierra Wireless hardware, firmware or software. Making this the wrong place to ask, IMHO.

Thanks for the reply I have posted on Ask Ubuntu hosted by stackoverflow. I thought this was the forum for MC Series of of Modems this is at least where contacting support points you.

What I am trying to do?

  1. Connect to a 4GX data provider to have internet connection.
  2. Monitor the signal strength in different locations(while still connected).
    — as the linux box will be mobile, I can then make signal strength map for future trips.
    I can provided more logs if necessary. I tried to cut it down so as not to have unrelated log information.
    Anyway, I will try the modemmanager development list. I will also see about putting modem out of MBIM mode this I think maybe the problem lies. Thank you for the pointer.

Ok I am able to get signal strength while connected from both the qmicli and mmcli.
The short answer is 16.04.1 LTS kernel 4.4.* is not new enough and does not support the qmi interfaces correctly. You need to upgrade kernel or use Ubuntu 16.10 or newer. Also the modemmanger likely needs to be upgraded. I used PPAs provided by Aleksander to get it working in 16.04 LTS short term.

Long Answer I was able to collect the logs above using this method Debuging.

I collected new logs at the request of one of the libmbim developers. From that he could see as can be seen above that it using AT+PPP. It was suggested I need a new kernel and modemmanager trying this worked.

Some notes on the modem. Using AT!USBCOMP? I was able to see that these modems where not configured for mbim only qmi. I did try mbim in 16.04 LTS but it still didn’t work and required an newer kernel and modem manager.

Reporting signal strength may not worry you but not using the correct interfaces also will limit your speed at least in my case.
When running with AT+PPP I was getting 35Mbps down and 18 Mbps up. Using the LTE interfaces I am getting 35-45 Mps Down and 23-29 Mbps Up

Please note that I’m probably not maintaining those PPAs for a long term; specially the 4.4 Kernel PPA with raw-ip support in qmi_wwan (what the MC74xx requires). I may maintain the ModemManager PPA for 16.04 for a while, though, given how bad Ubuntu/Canonical are in having ModemManager up to date.

For reference, if anyone interested: