LTE-modem profiles selection issue on FortiWiFI 40F 3G4G (Using 2 SIMMs)

Hi all,
**I have a FortiWiFi 40F 3G4G and would like to use 2 SIMMs (1 from Bell and 1 from Rogers). I created 2 Wireless Profiles and the 2nd SIMM not to function. Only the 1 is selected. When I remove the 2nd slot (Bell), Rogers profile is not selected. From my testing, only the 1st profile is selected all the time. Any 2, 3 or 4th profile are not selected automatically. **
Any help will be appreciated.

**FortiWiFi-40F-3G4G **
LTE Modem
Model EM7565
Firmware SWI9X50C_01.14.22.00
FortiWiFi-40F-3G4G # exec lte-modem wireless-profile list
ID Type Name APN PDP_Type Authen Username
** 1 0 Bell 0 0 **
**2 0 Rogers staticIP.apn 0 0 **

didn’t you should check with the vendor of this device on how to switch profile?

There’s an option on how change profile manually but, it should be automatic since, we will be using different vendors. I’m in Canada and it seems the option for our Telecom carriers are not there and it ends up using Generic Firmware. How can I request a firmware presence for Bell, Freedom Mobile, Telus etc… ?

if that is not appear in the list below, you need to use the Generic one.

BTW, if you need carrier PRI switch automatically, you might need to check the “AUTO-SIM” feature in AT!IMPREF command