Legato Yocto 15.04 Source Compilation


I am facing an toolchain error while building the Legato Yocto 15.04 source on Ubuntu 14.04. I have exported the required toolchain dir also. But still the compiler is unable to find the toolchain. Please find the below error message.

| Compiling legato-af for wp85
| Toolchain Dir: WP85_TOOLCHAIN_DIR /home/user/TI_Legato/LegatoYocto1504/build_bin/tmp/sysroots/x86_64-linux/usr/bin/armv7a-vfp-neon-poky-linux-gnueabi
| Toolchain Prefix: WP85_TOOLCHAIN_PREFIX arm-poky-linux-gnueabi-
| No toolchain found for target ‘ar6’.
| make: *** No rule to make target `wp85’. Stop.
| WARNING: /home/user/TI_Legato/LegatoYocto1504/build_bin/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/legato-af/git-r0/temp/run.do_compile.8557:1 exit 2 from
| ERROR: Function failed: do_compile (log file is located at /home/user/TI_Legato/LegatoYocto1504/build_bin/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/legato-af/git-r0/temp/log.do_compile.8557)
ERROR: Task 1268 (/home/user/TI_Legato/LegatoYocto1504/meta-swi/common/recipes-legato/legato-af/legato-af_git.bb, do_compile) failed with exit code ‘1’
NOTE: Tasks Summary: Attempted 2623 tasks of which 2620 didn’t need to be rerun and 1 failed.
No currently running tasks (2623 of 2641)

Summary: 1 task failed:
/home/user/TI_Legato/LegatoYocto1504/meta-swi/common/recipes-legato/legato-af/legato-af_git.bb, do_compile
Summary: There was 1 ERROR message shown, returning a non-zero exit code.
make: *** [image_bin] Error 1

Could someone please help solve this?



This issue will be solved with the next Legato/Yocto 15.05 release.

It’s possible to build legato-af by editing ‘meta-swi/common/recipes-legato/legato-af/legato.inc’ and adding at the end:

S = "${WORKDIR}/legato-15.04.0.Beta" SRC_URI = "http://downloads.sierrawireless.com/legato/1504/legato-15.04.0.Beta.tar.bz2" SRC_URI[sha256sum] = "2163a3c3f78b1dfc5c2e850475ebddb2772c27f5006521cb43ba9c5ba5b080e8"



Hi Jay,

Thanks for your input.

But I had already tried adding these 3 lines in the mentioned file. I get the following error during the beginning of the build process itself.

ERROR: ParseError at /home/user/TI_Legato/LegatoYocto1504/meta-swi/common/recipes-legato/legato-af/legato.inc:22: unparsed line: 'S = "/home/user/TI_Legato/legato-15.04.0.Beta”

So I exported these 3 explicitly in the shell prompt after which I could continue with the build process and got stuck with the before mentioned error.

Thanks and Regards,


It is due to a copy/paste error in my previous code (the ASCII code of the latest double-quote char was not the good one).
Correct code is:

S = "${WORKDIR}/legato-15.04.0.Beta"