Legato restart command

not its not related to the image with sierra image it works the same
related to our board/module only
we dont see difference in our board vs. mango

what gpio can prevent power of /reset?

How can i reproduce in mangoh green board?

we checked POWER_ON_N we don’t see something unusual

poweroff command also stuck in the same place

How can i reproduce in mangoh green board?

its seems module or board problem
we dont know what to do why its not resets?
wake up pins?
did you see it before at custom board?

Maybe you can see if the current consumption dropped significantly and see if it is in power off mode.

power consumption dropped but it no boot

then it is in power off mode. Please check POWER_ON_N.

what the problem can be with POWER_ON_N?
we work according to the Sierra doc regarding POWER_ON_N

If the POWER_ON_N signal is at high level, the module will be powered off

we dont have physical button but power_on_n is internally controlled according to doc

Here i tried on MangOH green board, if i type AT!POWERDOWN, module will be turned off.
After that if i put SW401 pin 1 (POWER_ON_N) to OFF and then ON, module will power on.

We put a physical button at POWER_ON_N and we did AT!POWERDOWN and after we pressed the button
the module starts loading
the mode is working
but software reboot is not and its stucks in the same place and to press the button doesnt help

Then I cannot reproduce the issue on MangOH green board.
I tried “reboot”, AT!RESET, both command can reboot the module.

what can be a problem ? look linux reboot at the end write to CPU command to reboot
CPU is configuration in the module with boot configuration and it not doing it
the module itself is not good? may be can you talk to R&D please?

we ordered the same module and we will put it in mango red
we dont know what the problem we cannot to debug the module itself?!?

can you try on mangOH green board and see if we have the same result?

BTW, I just tried on mangOH red board, i can still see module reboots after “reboot” is entered in console.